Project

General

Profile

Bug #12573

YouTube is the default search engine in the Unsafe Browser of 3.0~rc1

Added by spriver over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
05/20/2017
Due date:
% Done:

100%

Feature Branch:
bugfix/12540-disable-search-in-unsafe-browser
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Unsafe Browser

Description

YouTube is the default search engine in the Unsafe Browser of 3.0~rc1.
Typing in the address bar or the search field will search in YouTube instead of Google.

Associated revisions

Revision d134e864 (diff)
Added by anonym over 2 years ago

Unsafe Browser: remove the search bar.

It currently defaults to the wrong addon, but really its presence only
encourages unsupported usage so let's just remove it altogether.

Will-fix: #12573

Revision b896d7f7 (diff)
Added by intrigeri over 2 years ago

Drop obolete manual test: the Unsafe Browser has no visible search engine anymore (refs: #12573, #12253).

Revision dd35289e
Added by intrigeri over 2 years ago

Merge branch 'bugfix/12540-disable-search-in-unsafe-browser' into testing (Fix-committed: #12540, #10253, #12573)

History

#1 Updated by spriver over 2 years ago

I fuzzed around with the prefs.js of the Unsafe Browser, it seems that the two settings

"user_pref("browser.search.defaultenginename", "Google");
user_pref("browser.search.selectedEngine", "Google");"

don't change anything (at least with my tests done with changing the value to Bing, Twitter, etc).

#2 Updated by spriver over 2 years ago

Apparently the available search engines and settings for search are now stored in the (compressed) file search.json.mozlz4 (for guidance for decompression/compression to/from a plain text .json read http://forums.mozillazine.org/viewtopic.php?f=23&t=3023201&p=14708969).

It seems that the value (in the uncompressed .json) for changing the default search engine is the parameter "current":"".
We don't ship this file for the Unsafe Browser, maybe shipping such a file solves this problem, but simply copying the search.json.mozlz4 from .tor-browser/profile.default/ into /usr/share/tails/chroot-browsers/unsafe-browser/ won't do the trick (at least on a live system for testing purposes).

#3 Updated by intrigeri over 2 years ago

  • Affected tool set to Unsafe Browser

That's a regression, but I'm not setting priority >> normal as it doesn't affect the supported use case of the Unsafe Browser => feel free to postpone, and focus on other matters.

#4 Updated by intrigeri over 2 years ago

I suggest we simply hide the search box in the Unsafe Browser, since it's not needed for the intended use case. And perhaps we could do #12540 at the same time, for consistency.

#5 Updated by anonym over 2 years ago

  • Status changed from Confirmed to In Progress

#6 Updated by anonym over 2 years ago

  • Assignee changed from anonym to intrigeri
  • % Done changed from 0 to 50
  • QA Check set to Ready for QA
  • Feature Branch set to bugfix/12540-disable-search-in-unsafe-browser

intrigeri wrote:

I suggest we simply hide the search box in the Unsafe Browser, since it's not needed for the intended use case. And perhaps we could do #12540 at the same time, for consistency.

Sounds perfect to me! Please review'n'merge into testing!

#7 Updated by intrigeri over 2 years ago

Added b896d7f7051b76ec92aec8c212fc470b4de8febe on top so we don't keep an obsolete manual test around; this will address #10253.

#8 Updated by intrigeri over 2 years ago

Code review passes, will now build & test.

#9 Updated by intrigeri over 2 years ago

  • Status changed from In Progress to Fix committed
  • % Done changed from 50 to 100

#10 Updated by intrigeri over 2 years ago

  • Assignee deleted (intrigeri)
  • QA Check changed from Ready for QA to Pass

#11 Updated by intrigeri over 2 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF