Project

General

Profile

Bug #12568

Fix browser bookmarks persistence vs Tor Browser 7.0a4

Added by anonym over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
Persistence
Target version:
Start date:
05/19/2017
Due date:
% Done:

100%

Feature Branch:
bugfix/12568-fix-tor-browser-bookmarks-persistence
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Browser

Description

From 9abc143e9b2aa3fed0e565523687ea4884ab28aa:

    Partially fix browser bookmarks persistence for Tor Browser 7.0a4.

    Apparently this new Firefox will get the realpath of the places.sqlite
    symlink, get its parent directory and create places.sqlite-{shm,wal}
    there -- if the creation of these two files fail, it's like if there
    are no bookmarks, and no new ones can be added (the "Add bookmarks" 
    dialog won't even open). So we have to allow the creation of these
    files too.

    Unfortunately this is not enough. If the target file of the symlink
    doesn't exist it is interpreted as a corrupt database => the symlink
    is deleted and replaced with a fresh bookmarks database (inside the
    Tor Browser profile, not the persistent directory). So, if you already
    have persistent bookmarks from before it will work, but if enable it
    for the first time it won't work. This will be fixed later, and will
    be documented as a known issue in Tails 3.0~rc1.

Associated revisions

Revision 35bdf510 (diff)
Added by anonym over 2 years ago

Generate the Tor Browser bookmarks database from an sqlite dump.

Since Tor Browser 7.0a4 (Firefox 52.1.1esr) our places.sqlite symlink
cannot point to a non-existing file; it must point to an existing file
that is a valid Firefox bookmarks sqlite database, or else Tor Browser
will remove the symlink, replacing it with Firefox' default
places.sqlite.

Will-fix: #12568

Revision 638a8d17
Added by intrigeri over 2 years ago

Merge remote-tracking branch 'origin/bugfix/12568-fix-tor-browser-bookmarks-persistence' into testing (Fix-committed: #12568)

History

#1 Updated by anonym over 2 years ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10
  • Feature Branch set to bugfix/12568-fix-tor-browser-bookmarks-persistence

This WIP is not working in its current state: the database we create is "corrupt" according to Firefox.

#2 Updated by intrigeri over 2 years ago

  • Priority changed from Elevated to High

That's probably our worst regression in 3.0~ => bumping priority.

#3 Updated by anonym over 2 years ago

  • Assignee changed from anonym to intrigeri
  • % Done changed from 10 to 50
  • QA Check set to Ready for QA

Fixed! Note that the branch was force-pushed.

So we now ship our bookmarks in an sqlite dump instead of the old html approach. Sadly this makes managing our bookmarks quite a bit harder, but I don't see any other reasonable way to solve this problem: that the bookmarks must be in a places.sqlite database on the ISO. At least we don't seem to do this very often (last time was in 2014).

#4 Updated by intrigeri over 2 years ago

  • % Done changed from 50 to 60

Code review passes. Will now build & test since the affected scenario doesn't run on Jenkins.

#5 Updated by intrigeri over 2 years ago

intrigeri wrote:

Code review passes. Will now build & test since the affected scenario doesn't run on Jenkins.

#12461 doesn't want me to delegate the testing part to robots, so I'll do it by hand.

#6 Updated by intrigeri over 2 years ago

  • Status changed from In Progress to Fix committed
  • % Done changed from 60 to 100

#7 Updated by intrigeri over 2 years ago

  • Assignee deleted (intrigeri)
  • QA Check changed from Ready for QA to Pass

Tested by hand:

  • starting an ISO built from this topic branch, without persistence
  • upgrading 3.0~beta4 with persistent bookmarks with an ISO built from this topic branch
  • creating a persistent volume from an ISO built from this topic branch and adding persistent bookmarks

#8 Updated by intrigeri over 2 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF