Project

General

Profile

Feature #12562

Have a web analytics platform like Matomo

Added by sajolida over 2 years ago. Updated 8 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Infrastructure
Target version:
-
Start date:
05/18/2017
Due date:
% Done:

100%

Feature Branch:
Type of work:
Sysadmin
Blueprint:
Starter:
Affected tool:

Description

Stuff we could do with an analytics platform:

  • Analyze our installation funnel. See where people are coming from, where people drop the most, etc.
  • Analyze navigation patterns in pages involved in #9814.
  • Analyze search engine requests (#11649).
  • Analyze better the donation funnel.
  • Have better download stats (should be much easier with the new download page).
  • Maybe know which FAQ and Known issues are most frequent.
  • Have bits of info about where are people interested in Tails located in the world (especially on installation funnel).

Subtasks

Feature #12563: Install prototype of MatomoResolved

Feature #12728: Try to replace our current metrics with MatomoRejected

Feature #12729: Single out Tor Browser users in MatomoRejected

Feature #14601: Know which ressources we would need to run Matomo on our infrastructureRejected

Feature #15758: Investigate how Matomo handles URLs leading to the same resourcesRejected


Related issues

Blocks Tails - Bug #11651: Analyze most visited pages statistics In Progress 08/16/2016
Blocks Tails - Bug #11650: Analyze third-party search engine requests Confirmed 08/16/2016
Blocks Tails - Bug #11649: Analyze internal search engine requests Confirmed 08/16/2016

History

#1 Updated by sajolida over 2 years ago

  • Blocks Bug #11651: Analyze most visited pages statistics added

#2 Updated by sajolida over 2 years ago

  • Blocks Bug #11650: Analyze third-party search engine requests added

#3 Updated by sajolida over 2 years ago

  • Blocks Bug #11649: Analyze internal search engine requests added

#4 Updated by u over 2 years ago

@sajolida, may you please clarify what this ticket is about, what issues does it address that are currently not addressed? Thanks!

#5 Updated by BitingBird about 2 years ago

  • Status changed from Confirmed to In Progress

#6 Updated by BitingBird about 2 years ago

  • Target version deleted (2017)

#7 Updated by sajolida almost 2 years ago

  • Description updated (diff)

#8 Updated by sajolida almost 2 years ago

  • Description updated (diff)

#9 Updated by sajolida 8 months ago

  • Subject changed from Have a web analytics platform to Have a web analytics platform like Matomo
  • Status changed from In Progress to Rejected
  • Assignee deleted (sajolida)

I'm rejecting because I don't think we'll work on this any time soon.

At least first, I'd like to see how much we can get out logparser (the log parsing script I wrote) in a very cheap way. We could reopen this ticket later in the future.

Also available in: Atom PDF