Project

General

Profile

Bug #12556

The mergebasebranch option's base branch merge does not update submodules

Added by anonym over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Continuous Integration
Target version:
Start date:
05/17/2017
Due date:
% Done:

100%

Feature Branch:
bugfix/12556-mergebasebranch-update-submodules
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

So branches will build and run the test suite with the Git submodule state as if the base branch merge didn't happen, while Tails Git itself has the correct state.

Concrete example: feature/5630-deterministic-builds has feature/stretch as base branch. On May 5th we updated the Chutney submodule so Tor is not broken in the test suite. But when feature/5630* merges feature/stretch (due to mergebasebranch) it won't checkout the new Git submodule state, and that is why this branch still fails all tests using Tor.

Associated revisions

Revision 24c5d9d1 (diff)
Added by anonym over 2 years ago

Build system: also update submodules after merging the base branch.

... via the `mergebasebranch` build option.

Will-fix: #12556

Revision 963801f6
Added by intrigeri over 2 years ago

Merge remote-tracking branch 'origin/bugfix/12556-mergebasebranch-update-submodules' into testing (Fix-committed: #12556).

History

#1 Updated by anonym over 2 years ago

  • Status changed from Confirmed to In Progress
  • Assignee set to anonym
  • % Done changed from 0 to 50
  • QA Check set to Ready for QA
  • Feature Branch set to bugfix/12556-mergebasebranch-update-submodules

Note to self: look at Jenkins' build logs if this works.

#2 Updated by intrigeri over 2 years ago

  • Status changed from In Progress to 11
  • % Done changed from 50 to 100

#3 Updated by intrigeri over 2 years ago

  • Assignee deleted (anonym)
  • QA Check changed from Ready for QA to Pass

#4 Updated by intrigeri over 2 years ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF