Project

General

Profile

Feature #12517

Have a systematic thank you process for individual substantial donations

Added by u over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Fundraising
Target version:
Start date:
05/05/2017
Due date:
% Done:

0%

Feature Branch:
Type of work:
Discuss
Blueprint:
Starter:
Affected tool:

Description

As proposed in the feedback about the sponsor page, we'd also like to have individuals be able to be listed on the Partners page. However, in order to make that happen, what shall we tell them? Should we either tell them on the Become A Partner page that if they wish they can send us an email? Or should we thank them individually and ask if they want to be listed? Is it realistic that we will follow up on every single donation?


Related issues

Related to Tails - Feature #6972: Create a "Partners" page Resolved 05/05/2017

History

#1 Updated by emmapeel over 2 years ago

  • Status changed from New to Confirmed

#2 Updated by intrigeri over 2 years ago

  • Tracker changed from Bug to Feature
  • Category set to Fundraising

#3 Updated by u over 2 years ago

  • Parent task deleted (#6972)

#4 Updated by u over 2 years ago

#5 Updated by sajolida over 2 years ago

  • Target version set to Tails_3.1

#6 Updated by u over 2 years ago

I don't think that it's realistic to follow up on every donation as all this happens out of our sight.
So the best option would be to add this as a sentence to the donation page. I already created a part on the bottom about partnering, and would like to try to improve on it in order to make it clear that as an individual donor, you should contact us.

Individuals who donated large amounts in the past: we knew this happened everytime when it happened, right? So I believe if that happens again, we should simply rely on this old mechanism. And whenever it happens, send them an email.

I'll create a folder in the fundraising repository with template emails for saying thanks and asking individuals if they want to be listed.

#7 Updated by u over 2 years ago

  • QA Check set to Ready for QA

I've created individual_substantial.mdwn in partners_donations/ in the fundraising repository with a thank you email. Please review.

#8 Updated by sajolida over 2 years ago

  • Status changed from Confirmed to Resolved
  • Assignee deleted (sajolida)
  • QA Check deleted (Ready for QA)

In the past it has sometimes been hard to track individual donations because of the hard communications with our fiscal sponsors. Still, I think this should be fixed and we should be able to know when people give us big money. For example, some donors wouldn't care writing us proactively and instead wait and see if we get back to them. Also, telling individual to contact us on /donate might lead to too many emails to process and too many frustrating emails: "it's super cool you donated but it's not enough to be listed on the partners page, sorry!".

Other than that, ack on the email in fundraising.git :)

Also available in: Atom PDF