Project

General

Profile

Feature #12500

Entire MAC address spoofed

Added by sajolida over 2 years ago. Updated over 2 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Spoof MAC
Target version:
Start date:
05/02/2017
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

When starting 3.0~beta3 on a X200 with an internal Wi-Fi card from factory, I get the entire MAC address spoofed.

2.12~rc1 behaves as expected and only randomized the end of the MAC address.

History

#1 Updated by intrigeri over 2 years ago

  • Status changed from New to Confirmed

#2 Updated by intrigeri over 2 years ago

FWIW I can't reproduce this with a (wired) network interface in libvirt/QEMU. I wonder how sajolida noticed this, and whether this has anything to do with NetworkManager randomizing the MAC address when scanning for Wi-Fi networks.

Not a blocker, but still: sajolida, with which command did you notice this, and at which point during the network configuration process? (before/after having connected to a Wi-Fi AP?)

#3 Updated by intrigeri over 2 years ago

  • Status changed from Confirmed to Rejected
  • Assignee deleted (anonym)

Reproduced with a Broadcom BCM43225 Wi-Fi interface in some Acer laptop, before connecting to any Wi-Fi AP. The Journal says that the current (fully randomized) MAC address was set by NetworkManager for scanning, as expected. Once I've connected to a Wi-Fi AP, only the non-vendor bytes of the MAC address are randomized, as expected too. So I bet that sajolida checked while scanning and was thus confused. sajolida, please reopen if you can reproduce this outside of the Wi-Fi scanning phase.

#4 Updated by sajolida over 2 years ago

I'm sure I used macchanger -s to see the MAC. I'm not sure whether I was scanning or already connected but most likely I was scanning because I was doing lost of tests in a row for #12362.

Also available in: Atom PDF