Project

General

Profile

Feature #12493

Have Tails Upgrader automatically point to manual upgrade if running from an old version

Added by sajolida about 2 years ago. Updated over 1 year ago.

Status:
Confirmed
Priority:
Low
Assignee:
-
Category:
-
Target version:
-
Start date:
04/29/2017
Due date:
% Done:

0%

QA Check:
Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Yes
Affected tool:
Upgrader

Description

See #12392.

"Old" here means "definitely too old to have an IUK". We are currently publishing IUKs for 2 versions so version older than 12 weeks will never have IUKs.

Note that we might decide to publish more IUKs in the future. So it would be good to have a mechanism in place to remember updating this setting if we decide to ship more IUKs.

This mechanism would also become obsolete if we decide to do #11131#note-6.


Related issues

Related to Tails - Feature #12492: Instruct people with a version older than n-2 to do manual upgrade in /doc/upgrade/error/check Confirmed 04/29/2017

History

#1 Updated by sajolida about 2 years ago

  • Tracker changed from Bug to Feature

#2 Updated by sajolida about 2 years ago

  • Related to Bug #12392: Correct documentation regarding 'Check for updates' added

#3 Updated by sajolida about 2 years ago

  • Related to deleted (Bug #12392: Correct documentation regarding 'Check for updates')

#4 Updated by sajolida about 2 years ago

  • Blocks Bug #12392: Correct documentation regarding 'Check for updates' added

#5 Updated by u almost 2 years ago

  • Subject changed from Have Tails Upgrader automatically points to manual upgrade if running from an old version to Have Tails Upgrader automatically point to manual upgrade if running from an old version

#6 Updated by u almost 2 years ago

Next steps: Tails Upgrader should point to the manual upgrade if users are trying to upgrade a Tails version that is older than 12 weeks.

See https://tails.boum.org/contribute/how/code/
Code lives here: https://git-tails.immerda.ch/iuk/
Manual Upgrade we need to link to: https://tails.boum.org/upgrade/tails

#7 Updated by intrigeri almost 2 years ago

Next steps: Tails Upgrader should point to the manual upgrade if users are trying to upgrade a Tails version that is older than 12 weeks.

I think "12 weeks" needs to be adjusted a bit since we now provide automatic upgrades for the last 2 releases.

#8 Updated by u almost 2 years ago

  • Related to Feature #12492: Instruct people with a version older than n-2 to do manual upgrade in /doc/upgrade/error/check added

#9 Updated by sajolida over 1 year ago

  • Blocks deleted (Bug #12392: Correct documentation regarding 'Check for updates')

#10 Updated by u over 1 year ago

Next steps: Tails Upgrader should point to the manual upgrade if users are trying to upgrade a Tails version that is older than version n-2.

See https://tails.boum.org/contribute/how/code/
Code lives here: https://git-tails.immerda.ch/iuk/
Manual Upgrade we need to link to: https://tails.boum.org/upgrade/tails

Also available in: Atom PDF