Project

General

Profile

Bug #12490

Rename OS X as macOS on our website

Added by sajolida almost 3 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
04/28/2017
Due date:
% Done:

0%

Feature Branch:
https://github.com/cbrownstein/tails/tree/doc/12490-rename-os-x
Type of work:
End-user documentation
Blueprint:
Starter:
Yes
Affected tool:

Description

https://en.wikipedia.org/wiki/MacOS: "In 2016, Apple rebranded OS X to macOS, adopting the nomenclature that it uses for their other operating systems, iOS, watchOS, and tvOS."

It's not going to be very exciting but the longer we wait the more occurences we'll have to fix and the more translation strings we might break.


Related issues

Blocks Tails - Feature #13423: Core work 2017Q3: Technical writing Resolved 07/05/2017

History

#1 Updated by cbrownstein over 2 years ago

  • Assignee changed from sajolida to cbrownstein
  • Starter set to Yes

#2 Updated by sajolida over 2 years ago

I'm fine with you taking over this one (thanks!) but we should be extra careful about translations here.

By default, every string in which we will replace "OS X" with "macOS" will result in fuzzy translations in the PO files for all languages and so these strings will appear in English until the translators fix them. That's boring work for translators and some teams are not active anymore (like Farsi) so the strings will likely never be fixed.

You should try to see if it seems safe to also replace "OS X" with "macOS" in all the PO files. I don't know these languages enough to be sure that this is 100% fine so you should inspect a bit the occurrences of "OS X" in these translations to check if it looks safe enough.

Don't hesitate to ask for more guidance on setting up and using translation with ikiwiki.

#3 Updated by cbrownstein over 2 years ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from cbrownstein to sajolida
  • QA Check set to Ready for QA

I inspected the PO files. It appears safe to outright replace occurrences of "Mac OS X" with "macOS".

https://github.com/cbrownstein/tails/tree/doc/12490-rename-os-x

#4 Updated by cbrownstein over 2 years ago

  • Assignee changed from sajolida to cbrownstein
  • QA Check deleted (Ready for QA)

I'm taking this one back. I need to review my work more thoroughly because it's ready for QA.

#5 Updated by cbrownstein over 2 years ago

Before* it's ready for QA.

#6 Updated by cbrownstein over 2 years ago

  • Assignee changed from cbrownstein to sajolida
  • QA Check set to Ready for QA

#7 Updated by sajolida over 2 years ago

#8 Updated by sajolida over 2 years ago

  • Target version set to Tails_3.1

#9 Updated by sajolida over 2 years ago

#10 Updated by sajolida over 2 years ago

#11 Updated by intrigeri over 2 years ago

  • Feature Branch set to https://github.com/cbrownstein/tails/tree/doc/12490-rename-os-x

#12 Updated by sajolida over 2 years ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (sajolida)
  • QA Check deleted (Ready for QA)

Perfect, I'm merging!

Also available in: Atom PDF