Project

General

Profile

Feature #12470

Document how to start the screen reader with keyboard shortcuts

Added by mercedes508 over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Accessibility
Target version:
Start date:
04/22/2017
Due date:
% Done:

0%

Feature Branch:
doc/12470-accessibility-shortcuts
Type of work:
End-user documentation
Blueprint:
Starter:
Affected tool:
Greeter

Description

Some users needing screen reader at the beginning of Tails boot, will have to enable it at Greeter, which might already be difficult enough.

Would it be possible to make it enabled by default when installing Tails for example?


Related issues

Related to Tails - Feature #5501: Persistence preset: locale and accessibility options (language, keyboard, and formats) in Greeter Confirmed 12/31/2015
Blocks Tails - Feature #12432: Technical writing core work 2017Q2 Resolved 04/07/2017

History

#1 Updated by intrigeri over 2 years ago

  • Affected tool set to Greeter

#2 Updated by intrigeri over 2 years ago

  • Assignee set to mercedes508
  • QA Check set to Info Needed

Would it be possible to make it enabled by default when installing Tails for example?

It seems to me that this is essentially the same problem (be it in terms of UX or in terms of implementation details) as the one about needing to persist language and keyboard settings in clear-text (so that they're applied before one unlocks their persistent volume), which is well tracked on #12470. Would you be fine if I broadened the scope of #12470 to include this, and marked this very ticket as a duplicate?

#3 Updated by mercedes508 over 2 years ago

Sure, please do.

#4 Updated by mercedes508 over 2 years ago

  • Assignee changed from mercedes508 to intrigeri

#5 Updated by sajolida over 2 years ago

I think that making it easy to enable the screen reader from start is
different that storing this setting between boots, because:

  • If people need a screen reader then it should be easy to activate
    even if they don't have a persistent volume, their own Tails, or don't
    want to store that information in cleartext on the USB stick.
  • We have no schedule regarding the storage of language and
    keyboard preferences in persistence so if we can fix this ticket earlier
    and differently we should do it.

For example, could we have a keyboard shortcut to enable the screen
reader from Tails Greeter? Is there anything standard for this in GNOME?

#6 Updated by intrigeri over 2 years ago

  • Assignee changed from intrigeri to sajolida

I think that making it easy to enable the screen reader from start is different that storing this setting between boots, because: […]

OK, fair enough.

For example, could we have a keyboard shortcut to enable the screen reader from Tails Greeter? Is there anything standard for this in GNOME?

Yes. https://wiki.gnome.org/Design/OS/KeyboardShortcuts says that Alt+Super+S should be enough (and FTR each of Windows and macOS have others, different shortcuts). I've just verified it works fine in 3.0~beta4 (even though the change takes ~12 seconds to be effective here — MacBook Pro started from USB — as Orca startup needs to read quite some stuff from the USB stick). I'll let you decide if you want to turn this ticket into a Documentation one, or ask me to do the ticket mangling what I proposed earlier here, or simply close it as resolved.

#7 Updated by sajolida over 2 years ago

  • Related to Feature #5501: Persistence preset: locale and accessibility options (language, keyboard, and formats) in Greeter added

#8 Updated by sajolida over 2 years ago

  • Target version set to Tails_3.0
  • QA Check deleted (Info Needed)
  • Type of work changed from Discuss to End-user documentation

I bet you were referring to #5500 in #12470#notes-2. I added "accessibility" to its title. And for now, I'll document some keyboard shortcuts relevant to accessibility in the documentation for 3.0 as a solution for this ticket.

And I ack the "~12 seconds" to start the screen reader, whether or not it's started with a keyboard shortcut.

#9 Updated by sajolida over 2 years ago

#10 Updated by sajolida over 2 years ago

  • Assignee changed from sajolida to spriver
  • QA Check set to Ready for QA
  • Feature Branch set to doc/12470-accessibility-shortcuts

spriver: do you want to have a look? Otherwise try to assign it to cbrownstein.

#11 Updated by spriver over 2 years ago

  • Assignee changed from spriver to sajolida
  • Feature Branch changed from doc/12470-accessibility-shortcuts to spriver:doc/12470-accessibility-shortcuts

I'm fine with everything, I tested all documented keybindings etc.
I just added the method to select multiple items from the menu without closing it after each selection (by pressing space), if that's okay. If it's too much detail, ignore my commit and merge it as-is.

#12 Updated by intrigeri over 2 years ago

  • Subject changed from Having screen reader enable at startup to Document how to start the screen reader with keyboard shortcuts

#13 Updated by sajolida over 2 years ago

  • Status changed from Confirmed to Resolved
  • Assignee deleted (sajolida)
  • QA Check deleted (Ready for QA)
  • Feature Branch changed from spriver:doc/12470-accessibility-shortcuts to doc/12470-accessibility-shortcuts

I prefer Space much more than Enter! I originally copied this from some GNOME documentation without testing it enough it seems.

So actually I removed Enter in cc4a84ab32 and merged that.

Also available in: Atom PDF