Project

General

Profile

Bug #12463

Feature #12160: Upgrade all systems to Stretch

MariaDB backups on buse, ecours and puppet-git.lizard trigger useless/noisy email notifications since the upgrade to Stretch

Added by intrigeri over 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Infrastructure
Target version:
Start date:
04/20/2017
Due date:
% Done:

100%

Feature Branch:
Type of work:
Sysadmin
Blueprint:
Starter:
Affected tool:

Description

== warnings from /etc/backup.d/10.mysql ==

Info: Initializing SQL dump method
Info: Successfully finished dump of mysql database icinga2
Info: Successfully finished dump of mysql database icingaweb2
Warning: mysqldump: Couldn't execute 'SELECT /*!40001 SQL_NO_CACHE icinga2/ Lizard/
Tails/ zones.d/ icinga2 Lizard README Tails zones.d FROM `EVENTS`': Cannot proceed
because system tables used by Event Scheduler were found damaged at server start
(1577)
Warning: Failed to dump mysql databases information_schema
Info: Successfully finished dump of mysql database mysql
Info: Successfully finished dump of mysql database performance_schema

Related issues

Blocks Tails - Feature #13284: Core work: Sysadmin (Adapt our infrastructure) Confirmed 06/30/2017

History

#1 Updated by intrigeri about 2 years ago

  • Target version changed from Tails_3.0~rc1 to Tails_3.0

Sorry, no time to deal with this before next week. Thankfully the data in this DB is not that critical.

#2 Updated by intrigeri about 2 years ago

  • Status changed from Confirmed to In Progress
  • Target version changed from Tails_3.0 to Tails_3.1
  • % Done changed from 0 to 10

This is https://0xacab.org/riseuplabs/backupninja/issues/11148. I've reviewed the corresponding pull request and requested some fixes. Once it's done I'll upload with this patch applied to Debian so we can upgrade.

Thankfully this failure only affects the nformation_schema DB, that we don't care about backup'ing, so I propose we live with this email noise until the bug is fixed in backupninja: IMO the cost of implementing a temporary workaround is not worth it.

#3 Updated by intrigeri about 2 years ago

  • Subject changed from MySQL backups might be broken on ecours since it's been upgraded to Stretch to MySQL backups on ecours trigger useless/noisy email notifications since it's been upgraded to Stretch

#4 Updated by intrigeri about 2 years ago

  • Blocks Feature #13232: Core work 2017Q2: Sysadmin (Maintain our already existing services) added

#5 Updated by intrigeri about 2 years ago

  • Blocks Feature #13233: Core work 2017Q3: Sysadmin (Maintain our already existing services) added

#6 Updated by intrigeri about 2 years ago

  • Blocks deleted (Feature #13232: Core work 2017Q2: Sysadmin (Maintain our already existing services))

#7 Updated by intrigeri almost 2 years ago

Went through another review round, I'm confident there'll be a branch I can merge upstream shortly.

#8 Updated by intrigeri almost 2 years ago

  • Target version changed from Tails_3.1 to Tails_3.2

#9 Updated by intrigeri almost 2 years ago

  • Blocks deleted (Feature #13233: Core work 2017Q3: Sysadmin (Maintain our already existing services))

#10 Updated by intrigeri almost 2 years ago

  • % Done changed from 10 to 20

Fix finally merged in backupninja upstream. Next step is to get it into Debian → on our infra, somehow.

#11 Updated by intrigeri almost 2 years ago

  • Subject changed from MySQL backups on ecours trigger useless/noisy email notifications since it's been upgraded to Stretch to MariaDB backups on buse, ecours and puppet-git.lizard trigger useless/noisy email notifications since the upgrade to Stretch

#12 Updated by intrigeri almost 2 years ago

  • % Done changed from 20 to 30

Released backupninja 1.0.2 upstream with the fix, uploaded to sid. Once it's accepted and on the mirrors I'll add APT pinning to pull it from there.

#13 Updated by intrigeri almost 2 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 30 to 100

Upgraded these 3 hosts to 1.0.2-1.

#14 Updated by intrigeri almost 2 years ago

  • Blocks Feature #13284: Core work: Sysadmin (Adapt our infrastructure) added

Also available in: Atom PDF