Project

General

Profile

Feature #12399

Add support for debug cmdline option in Whisperback

Added by bertagaz over 2 years ago. Updated 5 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
03/20/2017
Due date:
% Done:

100%

Feature Branch:
feature/12399-support-for-debug-cmdline-option,https://gitlab.com/saschamarkus/whisperback/tree/feature/12399-support-for-debug-cmdline-option
Type of work:
Code
Blueprint:
Starter:
Affected tool:
WhisperBack

Description

As we've done with the Tails greeter (see #12373), Whispeback should output its debug logs in the journal if the debug option is set in /proc/cmdline.


Related issues

Related to Tails - Feature #12373: Greeter should honor "debug" kernel command line parameter Resolved 03/18/2017
Related to Tails - Feature #12396: Honor the "debug" kernel cmdline option in Tails Installer Confirmed 03/20/2017
Related to Tails - Feature #12395: Honor the "debug" kernel cmdline option in persistence-setup Confirmed 03/20/2017

History

#1 Updated by intrigeri over 2 years ago

  • Target version deleted (Tails_3.0)
  • Affected tool set to WhisperBack

#2 Updated by u over 1 year ago

  • Related to Feature #12373: Greeter should honor "debug" kernel command line parameter added

#3 Updated by u over 1 year ago

  • Related to Feature #12396: Honor the "debug" kernel cmdline option in Tails Installer added

#4 Updated by u over 1 year ago

  • Related to Feature #12396: Honor the "debug" kernel cmdline option in Tails Installer added

#5 Updated by u over 1 year ago

  • Related to deleted (Feature #12396: Honor the "debug" kernel cmdline option in Tails Installer)

#6 Updated by u over 1 year ago

  • Related to Feature #12395: Honor the "debug" kernel cmdline option in persistence-setup added

#7 Updated by sascha.markus@gmail.com 5 months ago

  • Assignee set to sascha.markus@gmail.com

#8 Updated by sascha.markus@gmail.com 5 months ago

  • Status changed from Confirmed to In Progress

#9 Updated by sascha.markus@gmail.com 5 months ago

  • Assignee changed from sascha.markus@gmail.com to intrigeri
  • QA Check set to Ready for QA
  • Feature Branch set to https://gitlab.com/saschamarkus/whisperback/tree/feature/12399-support-for-debug-cmdline-option

There wasn't any logging in the code.
Now there is debug logging to see which methods are called.
And a warning logged if config files are not found.

The code to check for the cmdline switch is borrowed from the greeter code for #12373

#10 Updated by segfault 5 months ago

  • Assignee changed from intrigeri to segfault

#11 Updated by segfault 5 months ago

  • Assignee deleted (segfault)
  • % Done changed from 0 to 100
  • QA Check changed from Ready for QA to Pass
  • Feature Branch changed from https://gitlab.com/saschamarkus/whisperback/tree/feature/12399-support-for-debug-cmdline-option to feature/12399-support-for-debug-cmdline-option,https://gitlab.com/saschamarkus/whisperback/tree/feature/12399-support-for-debug-cmdline-option

I branched off the branch of Sascha Markus and pushed a couple of fixup commits. Released in 1.7.22 and uploaded the Debian package.

#12 Updated by segfault 5 months ago

  • Status changed from In Progress to Fix committed
  • Target version set to Tails_3.14

#13 Updated by intrigeri 5 months ago

@segfault, it seems that you've uploaded this straight to the stable suite. That's fine but you need to be aware that this has a drawback: the devel suite still has the old version. Bypassing the usual process requires an additional manual operation, which I did:

ssh reprepro@incoming.deb.tails.boum.org reprepro copysrc devel stable whisperback

FTR, if you had gone the "upload to branch-specific suite" way, devel would have got the new package as soon as one merges the stable Git branch into devel, which is nice: it avoids some reprepro fiddling, ensures we'll mention this change in our Changelog, and encodes more stuff in Git :)

#14 Updated by segfault 5 months ago

intrigeri wrote:

@segfault, it seems that you've uploaded this straight to the stable suite.

Right. I should have noted that here, sorry I forgot about that. I've allowed myself to test this package by installing it in an existing 3.13.1 installation instead of building a feature branch, so I didn't target a feature branch. And I targeted stable instead of devel because I think that we might want to have this in 3.x and not wait until 4.0.

That's fine but you need to be aware that this has a drawback: the devel suite still has the old version. Bypassing the usual process requires an additional manual operation, which I did:

[...]

FTR, if you had gone the "upload to branch-specific suite" way, devel would have got the new package as soon as one merges the stable Git branch into devel, which is nice: it avoids some reprepro fiddling, ensures we'll mention this change in our Changelog, and encodes more stuff in Git :)

OK, thanks for the clarification. I will try to keep that in mind.

#15 Updated by intrigeri 5 months ago

  • Target version changed from Tails_3.14 to Tails_3.13.2

#16 Updated by anonym 5 months ago

  • Status changed from Fix committed to Resolved

#17 Updated by anonym 5 months ago

  • Target version changed from Tails_3.13.2 to Tails_3.14

#18 Updated by intrigeri 5 months ago

  • Target version changed from Tails_3.14 to Tails_3.13.2

Also available in: Atom PDF