Project

General

Profile

Bug #12385

The virtual keyboard in the Greeter allows to type only a limited set of keys

Added by intrigeri over 2 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Accessibility
Target version:
-
Start date:
03/19/2017
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Greeter

Description

Thanks to #5563 we now have a screen keyboard in the Greeter. That's a pretty good start!

Now, it supports only a few keyboard layouts, and even those are partial: e.g. when one selected French language and keyboard, I could not find any way to type "é". So users who need a screen keyboard won't be able to type the passphrase to unlock their persistent volume if it includes "special" characters.


Related issues

Related to Tails - Feature #8281: Consider replacing Florence with GNOME's own on-screen keyboard Resolved 11/20/2014
Related to Tails - Feature #5563: Add virtual keyboard to Tails Greeter Resolved
Related to Tails - Feature #8444: Monitor development of screen keyboard in GNOME Confirmed 12/16/2014

Associated revisions

Revision 6947000f (diff)
Added by intrigeri over 2 years ago

Specify what we accept, rather than an incomplete list of what we reject (refs: #12385).

Also, drop the bits about Let's Encrypt: it's already mentioned below, and it's
an implementation details that doesn't really belong to the big picture IMO.

Revision 9ddaa472 (diff)
Added by intrigeri over 2 years ago

Make it clear everywhere that we now require HTTPS too (refs: #12385).

Revision 6f0f354e (diff)
Added by intrigeri over 2 years ago

De-duplicate obsolete "Apache configuration example using a hostname under dl.amnesia.boum.org" section (refs: #12385).

The previously named "Apache configuration example using your own domain"
section should work as-is for *.dl.amnesia.boum.org as well, using one's
hostname instead of yourdomain.org. De-duplicating these sections avoids having
to maintain these config bits twice, which lead to only one of the being updated
and the other one left outdated, e.g.
37c6e78b582356a2867cbcd600976b59931ff91c.

Revision 62fe538c (diff)
Added by intrigeri over 2 years ago

Make it clear that answering HTTP requests is still required (refs: #12385).

Otherwise it gets harder to add mirrors to our fallback DNS round-robin pool,
that's not HTTPS-enabled yet.

History

#1 Updated by intrigeri over 2 years ago

  • Related to Feature #8281: Consider replacing Florence with GNOME's own on-screen keyboard added

#2 Updated by intrigeri over 2 years ago

  • Related to Feature #8444: Monitor development of screen keyboard in GNOME added

#3 Updated by intrigeri over 2 years ago

  • Related to Feature #5563: Add virtual keyboard to Tails Greeter added

#4 Updated by intrigeri over 2 years ago

This is essentially blocked by #8444, which has no assignee :/

#5 Updated by alant over 2 years ago

intrigeri wrote:

This is essentially blocked by #8444, which has no assignee :/

I assigned it to me.

#6 Updated by intrigeri over 2 years ago

I assigned it to me.

:)

#7 Updated by intrigeri over 2 years ago

  • Status changed from Confirmed to In Progress

#8 Updated by u about 2 years ago

intrigeri wrote:

Applied in changeset 6947000f688ab0b22270f9312867c1a3d8058987.

I think you might have typed a wrong bug number in this commit which has nothing to do with this ticket, but is about the mirror documentation.

#9 Updated by u about 2 years ago

  • Related to deleted (Feature #8444: Monitor development of screen keyboard in GNOME)

#10 Updated by u about 2 years ago

  • Related to Feature #8444: Monitor development of screen keyboard in GNOME added

#11 Updated by u about 2 years ago

Unable to test that currently due to #11872

#12 Updated by u about 2 years ago

  • Related to Bug #11872: Florence systray icon sometimes does not show up added

#13 Updated by u about 2 years ago

  • Related to deleted (Bug #11872: Florence systray icon sometimes does not show up)

#14 Updated by u about 2 years ago

Actually, all the character keys are there! :)
It's like on a smartphone: you need to press a key longer to see all alternatives. For example, press "e" longer and you'll get "ê, é, è". Same in german for äüö -> one needs to press "auo" for longer.

-> This will likely need documentation.

The remaining problems I see: there are no numbers in this keyboard and only three sign characters: ".,?" So if your passphrase contains "-/_:+*" for example, you have a real problem :)

-> This should probably be reported upstream, however, according to : https://help.gnome.org/users/gnome-help/stable/keyboard-osk.html.en There should be a possibility to switch between numbers and letters, so I wonder if we sort of don't load the full keyboard? This should first be investigated.

#15 Updated by intrigeri about 2 years ago

u wrote:

The remaining problems I see: there are no numbers in this keyboard

I see digits once I click the "123" button in the bottom left.

and only three sign characters: ".,?" So if your passphrase contains "-/_:+*" for example, you have a real problem :)

Most of them are available once going to the "123" mode, and all of them once going to the "{#*" mode.

#16 Updated by intrigeri about 2 years ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF