Project

General

Profile

Bug #12381

Feature #11916: Update doc for 3.0

Adjust to Nautilus not showing the full path of folders in Stretch

Added by spriver over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
03/19/2017
Due date:
% Done:

0%

Feature Branch:
Type of work:
End-user documentation
Blueprint:
Starter:
Affected tool:

Description

Affecting:
  • doc/first_steps/persistence/copy.mdwn

In the page regarding copying of the persistent volume we say: "In the file browser, navigate to /media/amnesia/TailsData to open the old persistent volume."
It's a bit difficult to navigate to that location without having an address bar to copy the location into and Nautilus is just showing a "relative" path in the address bar, e.g. when accessing an external volume (e.g. it's just "TailsData" in this particular example).
I'm proposing to simplify the documentation to just click on the volume "TailsData" in the left panel of Nautilus for accessing it directly. (doc/encryption_and_privacy/secure_deletion already describes it in a way similar to this)

For locations relatively to / (e.g. /live/persistence/TailsData_unlocked) I propose to describe something similar to "Choose Places -> Computer -> /live/persistence/TailsData_unlocked".


Related issues

Blocks Tails - Feature #12432: Technical writing core work 2017Q2 Resolved 04/07/2017

History

#1 Updated by intrigeri over 2 years ago

  • Status changed from New to Confirmed

#2 Updated by intrigeri over 2 years ago

  • Target version deleted (Tails_3.0)

This ticket has no assignee and the doc update is unclear to me (sajolida said today that he doesn't know if he can providing a timeline by the end of April), so I'm removing bonus stuff from the 3.0 milestone: please focus on the bits we really have to update.

#3 Updated by sajolida over 2 years ago

  • Subject changed from Simplify description of accessing ext. volumes with Nautilus in Stretch to Adjust to Nautilus not showing the full path of folders in Stretch
  • Assignee set to cbrownstein

Renaming the ticket to be more generic: this affects whenever we are telling people to navigate to a particular folder.

Another place that will be affected is #12109 (once I merge it). But then we need to be root, so instead of instructing to choose Places → Computer → /live/persistence/TailsData_unlocked from the top bar, what about instructing to choose Other Locations → Computer from Nautilus.

Tentatively assigning to cbrownstrein since he worked on #12109. cbrownstein: do you want to work on this one? You should do the work on a branch based on feature/stretch since this is for 3.0 only.

#4 Updated by cbrownstein over 2 years ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from cbrownstein to sajolida
  • QA Check set to Ready for QA

I've rewritten the instructions in doc/first_steps/persistence/copy.mdwn per sajolida's suggestion.

https://github.com/cbrownstein/tails/tree/doc/12381-nautilus-full-path

I'll hold off on doc/first_steps/persistence/configure.mdwn until #12109 is merged.

#5 Updated by sajolida over 2 years ago

#6 Updated by sajolida over 2 years ago

  • Target version set to Tails_3.0

#7 Updated by sajolida over 2 years ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (sajolida)
  • QA Check deleted (Ready for QA)

Excellent! I pushed few minor improvements on doc/12381-nautilus-full-path but I think that's ready to be merged.

#8 Updated by intrigeri over 2 years ago

Excellent! I pushed few minor improvements on doc/12381-nautilus-full-path but I think that's ready to be merged.

And indeed it's been merged, apparently :)

Also available in: Atom PDF