Project

General

Profile

Bug #12377

Tails Installer wrongly reports "impossible to upgrade" when SD card is plugged after Tails Installer started

Added by sajolida over 2 years ago. Updated almost 2 years ago.

Status:
Confirmed
Priority:
Normal
Assignee:
-
Category:
Installation
Target version:
-
Start date:
03/19/2017
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Installer

Description

After doing:

  • Upgrade my SD card with Tails Installer.
  • Unplug my SD card.

I do:

  • Restart Tails Installer.
  • Choose "Upgrade by cloning".
  • Plug my SD card again.
  • Tails Installer report my SD card as impossible to upgrade because not being installed by Tails Installer.
  • Still, I can click "Install" and upgrade.

If on the other hand I do:

  • Plug my SD card again.
  • Restart Tails Installer.
  • Choose "Upgrade by cloning".
  • Tails Installer doesn't report my SD card as impossible to upgrade.
  • I can click "Install" and upgrade.

History

#1 Updated by u over 2 years ago

@kurono, interested to look into this?

#2 Updated by kurono about 2 years ago

u wrote:

@kurono, interested to look into this?

It seems like I am not actually receiving notifications when I am assigned as watcher :O

#3 Updated by intrigeri about 2 years ago

Test.

#4 Updated by intrigeri about 2 years ago

It seems like I am not actually receiving notifications when I am assigned as watcher :O

Debugging this privately (via -sysadmins@).

#5 Updated by u almost 2 years ago

@kurono: would you like to have a look into this one at some point as well? :)

Also available in: Atom PDF