Project

General

Profile

Feature #12373

Feature #5464: Revamp Greeter interface

Feature #8230: Greeter revamp: Phase 1

Greeter should honor "debug" kernel command line parameter

Added by alant over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
-
Target version:
Start date:
03/18/2017
Due date:
% Done:

100%

Feature Branch:
feature/12373-honor-debug-kernel-cmdline
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Greeter

Description

To debug greeter issues, it would be very useful to have debug logs of the greeter. To do that, one currently need to set a root password, go to a text console, change a file and restart the greeter. Not only this is a comlplicated process, but it also make it impossible to debug issues that only happen at the 1st start of the greeter. Let's make the greeter set logging level to debug when it sees "debug" on the kernel command line.


Related issues

Related to Tails - Feature #12399: Add support for debug cmdline option in Whisperback Resolved 03/20/2017
Related to Tails - Feature #12396: Honor the "debug" kernel cmdline option in Tails Installer Confirmed 03/20/2017
Related to Tails - Feature #12395: Honor the "debug" kernel cmdline option in persistence-setup Confirmed 03/20/2017

Associated revisions

Revision e04e500a
Added by bertagaz over 2 years ago

Merge remote-tracking branch 'origin/feature/12373-honor-debug-kernel-cmdline' into feature/stretch

Fix-committed: #12373

History

#1 Updated by alant over 2 years ago

  • Subject changed from Greeter sould honor "debug" kernel command line parameter to Greeter should honor "debug" kernel command line parameter
  • Status changed from Confirmed to In Progress
  • Target version set to Tails_3.0
  • Feature Branch set to feature/12373-honor-debug-kernel-cmdline

This should be fixed in feature/12373-honor-debug-kernel-cmdline. Unfortunately local build is broken because of #12374. In ISO should be building on jenkins to test that branch.

#2 Updated by alant over 2 years ago

  • Assignee changed from alant to intrigeri
  • QA Check set to Ready for QA

This works in a real ISO. Please merge greeter's feature/12373-honor-debug-kernel-cmdline to feature/stretch.

#3 Updated by intrigeri over 2 years ago

  • Priority changed from Normal to Elevated
  • Parent task deleted (#12364)

#4 Updated by intrigeri over 2 years ago

  • Blocks Bug #12364: Race condition at greeter startup added

#5 Updated by intrigeri over 2 years ago

  • Assignee changed from intrigeri to bertagaz
  • % Done changed from 0 to 50

#6 Updated by bertagaz over 2 years ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (bertagaz)
  • % Done changed from 50 to 100
  • QA Check changed from Ready for QA to Pass

alant wrote:

This works in a real ISO. Please merge greeter's feature/12373-honor-debug-kernel-cmdline to feature/stretch.

Confirm it works. The journal gets bloated with a lot of other messages. It grows in size compared when started without debug, but not to a scary extend: after login, in a normal session it grows to 8Mb, with debug it grows to 24Mb, so that's still affordable. Merged!

#7 Updated by bertagaz over 2 years ago

  • Status changed from Fix committed to Resolved
  • QA Check deleted (Pass)

#8 Updated by alant over 2 years ago

  • Parent task set to #8230

#9 Updated by alant over 2 years ago

  • Blocks deleted (Bug #12364: Race condition at greeter startup)

#10 Updated by u over 1 year ago

  • Related to Feature #12399: Add support for debug cmdline option in Whisperback added

#11 Updated by u over 1 year ago

  • Related to Feature #12396: Honor the "debug" kernel cmdline option in Tails Installer added

#12 Updated by u over 1 year ago

  • Related to Feature #12395: Honor the "debug" kernel cmdline option in persistence-setup added

Also available in: Atom PDF