Project

General

Profile

Feature #12361

Document the removal of read-only persistence

Added by alant about 2 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
Persistence
Target version:
Start date:
03/17/2017
Due date:
% Done:

100%

QA Check:
Feature Branch:
Type of work:
Contributors documentation
Blueprint:
Starter:
Affected tool:

Description

The following documentation refer to read-only persistence, that we removed in 3.0:

  • first_steps/persistence/configure.mdwn
  • first_steps/persistence/upgrade.mdwn
  • first_steps/persistence/use.mdwn
  • first_steps/shutdown.mdwn

Related issues

Related to Tails - Bug #12093: Missing "Read only" option for persistence in new Greeter Rejected 12/28/2016

Associated revisions

Revision 3bcefef9
Added by sajolida about 2 years ago

Merge branch '12361' into feature/stretch (Will-fix: #12361)

Revision 6ce90a37 (diff)
Added by intrigeri about 2 years ago

Design doc: drop bits about read-only persistence (Closes: #12361).

History

#1 Updated by alant about 2 years ago

  • Related to Bug #12093: Missing "Read only" option for persistence in new Greeter added

#2 Updated by intrigeri about 2 years ago

  • Category set to Persistence

Glad we made a decision.

#3 Updated by cbrownstein about 2 years ago

  • Assignee changed from sajolida to cbrownstein
  • Starter set to Yes

Can the documentation simply be annotated to inform the user the read-only option applies only to < 3.0? What about vice versa: the read-only option does not apply to 3.0?

#4 Updated by sajolida about 2 years ago

We very rarely document changes themselves in the doc. We do it when some migration is required by the user or before removing big features but I don't think this applies here. Most of the time we only update the documentation to be in sync with what's actually implemented in the current Tails.

I would say that this ticket is only about updating the documentation to stop mentioning the read-only persistence in time for 3.0.

We do this by doing a Git branch from feature/stretch (the base branch for 3.0) and updating the doc there. It will then be applied automatically to the website when 3.0 get released.

Very happy if you take it over!

#5 Updated by cbrownstein about 2 years ago

  • Assignee changed from cbrownstein to sajolida
  • QA Check set to Ready for QA

Understood. I've deleted references to the "read-only" persistence option.

https://github.com/cbrownstein/tails/tree/12361

#6 Updated by sajolida about 2 years ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from sajolida to intrigeri
  • QA Check changed from Ready for QA to Info Needed
  • Starter deleted (Yes)

Thanks for taking that work from my plate! Your branch was perfect so I merged it into feature/stretch.

And you correctly branched it from feature/stretch, that's so cool you figured that out by yourself.

Regarding the naming of branches, we use loose a convention of naming documentation branches doc/XXXXX-some-short-description, where XXXXX is the ticket number. When dealing with many branches I find the short description useful to recognize which branch I'm dealing with (as I don't have all the ticket numbers in mind, thankfully!). But if you prefer it differently, I'll deal with it.

I'm reassigning to intrigeri and removing the Easy flag because I see mentions of this feature the design documentation.

intrigeri: Will you take care of it? Shall I reassign to Alan? Try to do it myself?

#7 Updated by intrigeri about 2 years ago

  • % Done changed from 0 to 50
  • QA Check changed from Info Needed to Dev Needed
  • Type of work changed from End-user documentation to Contributors documentation

I'll do it.

#8 Updated by intrigeri about 2 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 50 to 100

#9 Updated by intrigeri about 2 years ago

  • Assignee deleted (intrigeri)
  • Target version changed from Tails_3.0 to Tails_3.0~rc1
  • QA Check deleted (Dev Needed)

Also available in: Atom PDF