Project

General

Profile

Bug #12334

Gnome freeze with Intel Skylake GPU

Added by goupille over 2 years ago. Updated almost 2 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Hardware support
Target version:
-
Start date:
03/13/2017
Due date:
% Done:

0%

Feature Branch:
Type of work:
Research
Blueprint:
Starter:
Affected tool:

Description

Itel skylake GPU can be identified as Intel HD 530.

the freeze happens with 2.11 and 3.0~beta, the troubleshooting mode works but the resolution is really low. users experiencing this issue should test a 2.12 nightly experimental ISO (the kernel is upgraded to 4.9) :

https://nightly.tails.boum.org/build_Tails_ISO_devel/lastStable/archive/build-artifacts/


Related issues

Related to Tails - Bug #15821: Video playback broken on some Intel graphics cards (regression in 3.9~rc1) Resolved 08/20/2018

History

#1 Updated by intrigeri over 2 years ago

  • Category set to Hardware support

the freeze happens with 2.11 and 3.0~beta,

Note that "3.0~beta" is ambiguous as we've already released 3 beta versions of 3.0 :)

users experiencing this issue should test a 2.12 nightly experimental ISO (the kernel is upgraded to 4.9) :

Yes, this, and also 3.0~beta3 please :)

Cheers!

#2 Updated by goupille over 2 years ago

it was reproduced with tails 3.0~beta1, 3.0~beta2, and devel-2.12-20170313. debugging info have been asked (as well as testing beta3)...

#3 Updated by emmapeel over 2 years ago

How is this freeze? A blue screen after the Greeter?

#4 Updated by goupille over 2 years ago

at least in tails 2.12, with 'debug nopslash' add to the boot command line, the last line shows :

fb: switching to inteldrmfb from EFI VGA

#5 Updated by goupille over 2 years ago

to be clear : the boot process stops before the greeter

#6 Updated by intrigeri over 2 years ago

  • Subject changed from Gnome freeze with Intel skylake GPU to Gnome freeze with Intel Skylake GPU

Thanks. Please also get test results for https://nightly.tails.boum.org/build_Tails_ISO_feature-stretch-intel-video/lastSuccessful/archive/build-artifacts/.

Then I used my preferred web search engine and found some leads (I'm not convinced it's my job to do this kind of preliminary research, but whatever):

  • it seems to be known that Skylake GPUs are still poorly supported on Linux
  • make sure that the IGD aperture size in BIOS is less than 4GB
  • add i915.enable_rc6=0 to the kernel command line

Also, there seems to be some confusion going on: why is the ticket titled "GNOME freeze" if the problem happens before the Greeter? Maybe there are actually two different issues?

#7 Updated by mercedes508 about 2 years ago

  • QA Check set to Info Needed

Any way os asking if it still happen with Tails 3.3?
If not, please close it.

#8 Updated by goupille almost 2 years ago

  • Status changed from New to Rejected

I don't remember receiving a report concerning skylake since a few months, it should be more or less supported byt the kernel by now, so I'm closing this ticket.

#9 Updated by goupille almost 2 years ago

  • Assignee deleted (goupille)

#10 Updated by intrigeri over 1 year ago

  • Related to Bug #15821: Video playback broken on some Intel graphics cards (regression in 3.9~rc1) added

Also available in: Atom PDF