Project

General

Profile

Bug #12313

zenity dialogs have excessive height and/or width

Added by segfault over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
-
Target version:
Start date:
03/08/2017
Due date:
% Done:

100%

Feature Branch:
bugfix/12313-zenity
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

When starting the unsafe browser in Tails 3.0~beta1, the "Do you really want to launch the Unsafe Browser?" dialog has a lot bigger height than would be necessary. I encountered the same issue in dialogs in Tails Server, so I already know the solution to this is to disable word wrapping. In zenity this can be done with --no-wrap. I did not look for other zenity dialogs which might also be affected.

Screenshot from 2017-03-10 11-29-48.png View (22.7 KB) segfault, 03/10/2017 11:30 AM

Screenshot from 2017-03-10 11-29-53.png View - minimized width (24.3 KB) segfault, 03/10/2017 11:30 AM

fix-wrap.patch View - Fix the lack of wrap (1.07 KB) alant, 03/17/2017 08:41 PM

Associated revisions

Revision a972a46c
Added by intrigeri over 2 years ago

Merge branch 'bugfix/12313-zenity' into feature/stretch (Closes: #12313).

History

#1 Updated by intrigeri over 2 years ago

  • Status changed from New to Confirmed
  • Assignee set to segfault
  • QA Check set to Info Needed

Ouch, that's supposed to have been fixed a couple years ago. Can you please how this relates to #7234, https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=702295 and https://bugzilla.gnome.org/show_bug.cgi?id=670496?

#2 Updated by segfault over 2 years ago

Can you please how this relates to #7234, https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=702295 and https://bugzilla.gnome.org/show_bug.cgi?id=670496?

Seems to be the same problem, which was somehow reintroduced in Stretch. I also saw the same in the "Upgrade to 3.0~beta2" dialog today. What's striking is that all the height is exactly filled when you minimize the width manually (see the attached screenshot).

#3 Updated by intrigeri over 2 years ago

Do you intend to work towards having this bug fixed in Tails 3.0 (and ideally, upstream and in Debian Stretch), or should I?

#4 Updated by segfault over 2 years ago

Do you intend to work towards having this bug fixed in Tails 3.0 (and ideally, upstream and in Debian Stretch), or should I?

Like I wrote in the description, a workaround is to use --no-wrap. I think this is an acceptable fix for Tails 3.0. I don't have time to put more work into figuring out what caused this bug to reappear and fixing things upstream.

#5 Updated by segfault over 2 years ago

  • Assignee deleted (segfault)
  • QA Check deleted (Info Needed)

#6 Updated by intrigeri over 2 years ago

  • Assignee set to intrigeri

Thanks!

#7 Updated by intrigeri over 2 years ago

  • Assignee changed from intrigeri to alant
  • Priority changed from Normal to Elevated

#8 Updated by alant over 2 years ago

I reopoend the bugs at GNOME (https://bugzilla.gnome.org/show_bug.cgi?id=670496) and debian (https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=702295).

I see two possible workarounds:

  • building our own package with a patch (yet to write)
  • adding a /usr/local/bin/zenity wrapper with --no-wrap

Do we have a preffered option?

#9 Updated by alant over 2 years ago

  • Assignee deleted (alant)

After investigating the issue, it turns out it's related to a change or a bug in new in GTK: zenity 3.22.0 built with GTK 3.14.5-1+deb8u1 doesn't have the issue. The same zenity built with GTK 3.22.9-3 has the issue. I reported my findings upstream, but won't do more for now.

#10 Updated by intrigeri over 2 years ago

alant wrote:

  • adding a /usr/local/bin/zenity wrapper with --no-wrap

Alan says me it's wrong as it triggers a worse bug: the window becomes so wide the text is unreadable.

#11 Updated by intrigeri over 2 years ago

  • Assignee set to intrigeri

#12 Updated by intrigeri over 2 years ago

Apparently windows can be too wide anyway (essentially: no wrapping) which might make text unreadable. Alan didn't test if our own use cases are affected, so someone else needs to do it.

#13 Updated by alant over 2 years ago

The attached patch fixes the lack of wrapping, but doesn't fix the excessive height.

#14 Updated by alant over 2 years ago

  • Assignee set to intrigeri

The height bug seems to be https://bugzilla.gnome.org/show_bug.cgi?id=657621, open since... 2011

#15 Updated by alant over 2 years ago

I proposed a patch that fixes the issue at https://bugzilla.gnome.org/show_bug.cgi?id=670496#c12.

#16 Updated by intrigeri over 2 years ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from intrigeri to alant
  • % Done changed from 0 to 30

Alan is still working on this.

#17 Updated by intrigeri over 2 years ago

  • Subject changed from zenity dialogs have excessive height to zenity dialogs have excessive height and/or width

#18 Updated by alant over 2 years ago

  • Assignee changed from alant to intrigeri
  • QA Check set to Ready for QA
  • Feature Branch set to feature/12313-zenity

feature/12313-zenity includes a fixed zenity package.

#19 Updated by intrigeri over 2 years ago

  • Feature Branch changed from feature/12313-zenity to bugfix/12313-zenity

#20 Updated by intrigeri over 2 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 30 to 100

#21 Updated by intrigeri over 2 years ago

  • Assignee deleted (intrigeri)
  • QA Check changed from Ready for QA to Pass

I'll now try to get this into Debian Stretch.

Also available in: Atom PDF