Project

General

Profile

Feature #12289

Deal with June 2017 false positive scenarios

Added by anonym over 2 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Continuous Integration
Target version:
Start date:
06/05/2017
Due date:
07/05/2017
% Done:

100%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

As defined in #10993, check is there are still some of them and tag them as fragile if any (see #10288).


Related issues

Related to Tails - Bug #13461: The Desktop icons are sometimes not displayed since the upgrade to Stretch Resolved 07/12/2017
Related to Tails - Bug #13460: Virt-viewer fails to start Confirmed 07/12/2017
Related to Tails - Bug #13459: Scenario "Booting Tails from a USB drive in UEFI mode" is fragile Confirmed 07/12/2017
Related to Tails - Bug #13458: Step "a screenshot is saved to the live user's Pictures directory" is fragile Confirmed 07/12/2017
Related to Tails - Bug #13462: Memory erasure on boot medium removal is fragile Confirmed 07/12/2017
Related to Tails - Bug #13469: Starting applications "via GNOME Activities Overview" step is fragile Resolved 07/14/2017
Related to Tails - Bug #13470: Step "Tails Greeter has applied all settings" is fragile Resolved 07/14/2017
Related to Tails - Bug #13541: Tor still sometimes fails to bootstrap in the test suite In Progress 07/31/2017

History

#1 Updated by anonym over 2 years ago

  • Start date changed from 06/06/2017 to 06/05/2017

#2 Updated by anonym over 2 years ago

  • Category set to Continuous Integration

#3 Updated by anonym over 2 years ago

Now that we are close to 3.0 and feature/stretch being merged, let's down-prioritize new robustness issues in stable and devel in the sense that we ignore the issue unless we find proof that it also affects feature/stretch. This might mean that we ignore an issue that actually affects feature/stretch but isn't visible due to something breaking earlier in the affected tests, but let's prefer that risk over identifying and tracking issues that don't affect Tails after Jessie.

Of course, this month feature/stretch will be merged, so from that date on, disregard the above instructions.

#4 Updated by bertagaz over 2 years ago

  • Related to Bug #13461: The Desktop icons are sometimes not displayed since the upgrade to Stretch added

#5 Updated by bertagaz over 2 years ago

  • Related to Bug #13460: Virt-viewer fails to start added

#6 Updated by bertagaz over 2 years ago

  • Related to Bug #13459: Scenario "Booting Tails from a USB drive in UEFI mode" is fragile added

#7 Updated by bertagaz over 2 years ago

  • Related to Bug #13458: Step "a screenshot is saved to the live user's Pictures directory" is fragile added

#8 Updated by bertagaz over 2 years ago

  • Related to Bug #13462: Memory erasure on boot medium removal is fragile added

#9 Updated by bertagaz over 2 years ago

  • Related to Bug #13469: Starting applications "via GNOME Activities Overview" step is fragile added

#10 Updated by bertagaz over 2 years ago

  • Related to Bug #13470: Step "Tails Greeter has applied all settings" is fragile added

#11 Updated by bertagaz over 2 years ago

  • Status changed from Confirmed to In Progress
  • Assignee deleted (bertagaz)
  • % Done changed from 0 to 80

I've reviewed all June tests failures in Jenkins, they now all have tickets and are tagged in Jenkins. Sent an email on tails-ci about this review.

#12 Updated by bertagaz over 2 years ago

  • Assignee set to bertagaz

Oops

#13 Updated by bertagaz about 2 years ago

  • Related to Bug #13541: Tor still sometimes fails to bootstrap in the test suite added

#14 Updated by bertagaz about 2 years ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (bertagaz)
  • % Done changed from 80 to 100

Ok, added the last new ticket as discussed on tails-ci@ about Tor bootstraping issue still present, so I think this task is completed now.

Also available in: Atom PDF