Project

General

Profile

Feature #12288

Deal with May 2017 false positive scenarios

Added by anonym almost 3 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Continuous Integration
Target version:
Start date:
05/05/2017
Due date:
06/05/2017
% Done:

100%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

As defined in #10993, check is there are still some of them and tag them as fragile if any (see #10288).


Related issues

Blocks Tails - Feature #12604: Remove the feature/stretch Jenkins jobs Resolved 05/26/2017
Blocks Tails - Feature #13239: Core work 2017Q3: Test suite maintenance Resolved 06/29/2017

History

#1 Updated by anonym almost 3 years ago

  • Category set to Continuous Integration

#2 Updated by anonym almost 3 years ago

Now that we are close to 3.0 and feature/stretch being merged, let's down-prioritize new robustness issues in stable and devel in the sense that we ignore the issue unless we find proof that it also affects feature/stretch. This might mean that we ignore an issue that actually affects feature/stretch but isn't visible due to something breaking earlier in the affected tests, but let's prefer that risk over identifying and tracking issues that don't affect Tails after Jessie.

#3 Updated by anonym over 2 years ago

  • Blocks Feature #12604: Remove the feature/stretch Jenkins jobs added

#4 Updated by anonym over 2 years ago

  • Target version changed from Tails_3.0 to Tails_3.1

#5 Updated by anonym over 2 years ago

  • Blocks Feature #13239: Core work 2017Q3: Test suite maintenance added

#6 Updated by anonym over 2 years ago

  • Target version changed from Tails_3.1 to Tails_3.2

#7 Updated by intrigeri over 2 years ago

  • Status changed from Confirmed to Resolved
  • Assignee deleted (anonym)
  • Target version changed from Tails_3.2 to Tails_3.1
  • % Done changed from 0 to 100

Dropping the ball: we now have a full month with many more Stretch test runs.

Also available in: Atom PDF