Project

General

Profile

Bug #12273

Chinese input doesn't work in Unsafe browser.

Added by wydew1 over 2 years ago. Updated over 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
Accessibility
Target version:
-
Start date:
02/28/2017
Due date:
% Done:

0%

Feature Branch:
Type of work:
Discuss
Blueprint:
Starter:
Affected tool:
Unsafe Browser

Description

The Chinese input method is the only way to input chinese word by keyboard. To activated this is pressing Ctrl + Space in any environment where can input letters. It works in libreoffice, while doesn't work in the browser in latter versions. But it works in early versions such as Ver1.2(So I'm still using this:).

After choose Chinese tab and login into the system, under any circumstance where can inputting letters, when Ctrl + Space is pressed, the Chinese input method should be activated. On the top right corner bar there will be an icon to identify this.

11.jpg View - in ver2.10 pinyin in browser doesn't work (58.9 KB) wydew1, 03/01/2017 09:14 AM

22.jpg View - in v1.2 pinyin is OK (60.5 KB) wydew1, 03/01/2017 09:14 AM


Related issues

Related to Tails - Bug #9767: IBus input methods cannot be used in the chrooted browsers Confirmed 07/19/2015

History

#1 Updated by mercedes508 over 2 years ago

Hi,

I'm not sure to get you issue, it might have changed since Debian moved to Jessie and Gnome3 (https://wiki.debian.org/gnome-chinese-input)

Because when logging in Tails with Chinese input at Greeter, then you can select your prefered input method from the top-right corner (pinyin, anthy,...).

#2 Updated by wydew1 over 2 years ago

mercedes508 wrote:

Hi,

I'm not sure to get you issue, it might have changed since Debian moved to Jessie and Gnome3 (https://wiki.debian.org/gnome-chinese-input)

Because when logging in Tails with Chinese input at Greeter, then you can select your prefered input method from the top-right corner (pinyin, anthy,...).

Whether in ver1.2 or ver2.10 the way of selecting pinyin is the same, but the result is different in browser. Here are pictures to explain.

#3 Updated by mercedes508 over 2 years ago

  • Subject changed from In latter versions the Chinese input method can't be activated in browser. to Chinese input doesn't work in Unsafe browser.
  • Category set to Accessibility
  • Status changed from New to Confirmed
  • Type of work changed from Code to Discuss
  • Affected tool set to Unsafe Browser

It looks like you're trying it in the Unsafe Browser.

I just tried and effectively it doesn't work in the Unsafe Browser, but works fine in Tor browser.

As you might know, Unsafe Browser is designed to log in captive portals (https://tails.boum.org/doc/anonymous_internet/unsafe_browser/), does Chinese input has to be working for this very specific use?

#4 Updated by mercedes508 over 2 years ago

  • Assignee set to wydew1

#5 Updated by intrigeri over 2 years ago

  • QA Check set to Info Needed

(I guess this is broken for the same reason as accessibility technologies don't work in our "special" browsers.)

#6 Updated by wydew1 over 2 years ago

mercedes508 wrote:

It looks like you're trying it in the Unsafe Browser.

I just tried and effectively it doesn't work in the Unsafe Browser, but works fine in Tor browser.

As you might know, Unsafe Browser is designed to log in captive portals (https://tails.boum.org/doc/anonymous_internet/unsafe_browser/), does Chinese input has to be working for this very specific use?

Yes, I have to use Unsafe Browser. The reason will be related to another old topic that TOR doesn't work in China due to the state censorship firewall and maybe only a few very special org or person can visit TOR. (There're some 'easy' solutions to bypass the firewall in windows, but a little difficult in debian.)
For present if I don't choose Unsafe Browser, it seems I have no other choice. And not all situations have to use TOR.

#7 Updated by mercedes508 over 2 years ago

  • Status changed from Confirmed to Rejected

this is clearly off-topic here, but did you try obfs4 bridges?

Because if you use Tails for its Unsafe Browser, it clearly doesn't offer what Tails has been made for.

I'm marking this ticket as rejected accordingly.

#8 Updated by wydew1 over 2 years ago

mercedes508 wrote:

this is clearly off-topic here, but did you try obfs4 bridges?

Because if you use Tails for its Unsafe Browser, it clearly doesn't offer what Tails has been made for.

I'm marking this ticket as rejected accordingly.

Every means has been tried, including obfs4,etc, and failed.
So for people there, 1. They can't visit TOR and they can't use Normal browser. 2. They can't input their language in unsafe browser and unsafe browser will not be their choice, too. Since there's no browser to use, this result in The meaning of Tails is of insignificance for the people their.

Tails is not strong enough, it can only work in relatively 'free' countries in which TOR can be access, but for those 'hard' countries that blocking TOR, it's useless and worse than windows. And still thanks for bring in those interesting views in the old version.

#9 Updated by intrigeri over 2 years ago

  • Status changed from Rejected to New

Because if you use Tails for its Unsafe Browser, it clearly doesn't offer what Tails has been made for.

IMO rejecting this ticket might have been a tiny bit too hasty. Taking a step back, I can think of two reasons to use the Unsafe Browser, that might require supporting non-Latin input methods:

  • logging into a captive portal (some ask to enter various information that might); this is the very reason why we have an Unsafe Browser, and IMO it should work for people who need to input non-Latin text as well; wydew1, is this a plausible situation we should try to support?
  • getting bridge addresses: maybe this can require typing non-Latin text?

Since there's no browser to use, this result in The meaning of Tails is of insignificance for the people their.

As mercedes508 said, Tails is not meant for non-torified web browsing using the Unsafe Browser. That's simply not part of the use cases Tails is made for. There are plenty of other options to browse the web without Tor, so I don't understand why Tails should try to satisfy this use case. If that's what you were asking about: can you please clarify?

Now, if you need to use the Unsafe Browser in order to get obfs4 bridges addresses, then in my opinion that's a totally valid use case. Is it what's happening? If yes, can you please elaborate about how exactly one needs to use a Chinese input method to get an obfs4 bridge address? (I'm sorry I really have no clue.)

Regarding obfs4: there's a number of people using it successfully in China. I'm sorry it didn't work for you, and that would be worth investigating. Please file a dedicated bug report about it, with all the debugging information you can provide. Thanks!

#10 Updated by u over 2 years ago

@wydew1, can you provide any debugging information? Which bridges you tried for example?

#11 Updated by u over 2 years ago

  • Status changed from New to Duplicate

I just realized that this is a duplicate of #9767. Closing.

#12 Updated by u over 2 years ago

  • Related to Bug #9767: IBus input methods cannot be used in the chrooted browsers added

Also available in: Atom PDF