Project

General

Profile

Bug #12258

Feature #12160: Upgrade all systems to Stretch

Jenkins is not creating jobs for new branches

Added by anonym almost 3 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Continuous Integration
Target version:
Start date:
02/23/2017
Due date:
% Done:

100%

Feature Branch:
Type of work:
Sysadmin
Blueprint:
Starter:
Affected tool:

Description

I pushed the following branches days ago but no Jenkins jobs were created:
  • test/12131-retry-report-an-error
  • test/11508-possible-packetfu-bug

History

#1 Updated by intrigeri almost 3 years ago

  • Parent task set to #12160

#2 Updated by intrigeri almost 3 years ago

  • Category changed from Infrastructure to Continuous Integration

I'll handle it as part of my #12160 duty.

#3 Updated by intrigeri almost 3 years ago

  • Status changed from Confirmed to Resolved
  • Assignee deleted (intrigeri)
  • % Done changed from 0 to 100

Fixed.

Post-mortem: we missed the breakage because the git push that was failing (due to a hook that sanity-checks the generated jobs, that needed to be updated for Stretch) needs 2>/dev/null due to Git spitting out non-errors to STDERR. Ideally we would filter out the bits we don't want to see from STDERR, instead of ignoring it entirely. I've made sure that update_tails_iso_jobs itself sends something to STDERR, so that cron tells us about the breakage, whenever that git push exits with a non-zero exit code.

bertagaz: we should try to remember harder that set -e is not enough in a cronjob, as cron ignores the command's exit status, and only emails us if there was any output.

#4 Updated by anonym almost 3 years ago

  • Status changed from Resolved to In Progress
  • Assignee set to intrigeri
  • % Done changed from 100 to 80
  • QA Check set to Dev Needed

The branches in the description have no Jenkins jobs still; IMHO this branch shouldn't be closed before all lost jobs are created, if possible. I'd at least want my above branches to be created without me having to push some nonsense to them just to make Jenkins notice them.

What are our options here?

#5 Updated by intrigeri almost 3 years ago

  • Priority changed from Elevated to High

The branches in the description have no Jenkins jobs still; IMHO this branch shouldn't be closed before all lost jobs are created, if possible.

Crap! I'm sure I checked that they did have Jenkins jobs when I closed this ticket.

What are our options here?

I'll look into it shortly. Sorry!

#6 Updated by intrigeri almost 3 years ago

feature-12271-i2p-removal-notification and feature-12272-vagrant-offline-builds were automatically created yesterday, so the process seems to be mostly working, but I dunno why these two other branches had no job created.

#7 Updated by intrigeri almost 3 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 80 to 100
  • QA Check deleted (Dev Needed)

test/12131-retry-report-an-error was merged into stable, and our CI design is only about topic branches that were not merged yet. Generally merging the current base branch into the topic branch is enough to force Jenkins to build it again. But it won't work in this case as that topic branch is in the exact same state as stable currently. The good news is that this means you already get the CI results you want from the stable branch :)

Same for the other branch.

So it seems to me that the system works as designed, and that practical use cases we thought about are addressed already, so closing this ticket (the 2 branches Jenkins creates no job for are definitely not "new"). If this design doesn't work for you, please describe your use case in another ticket.

#8 Updated by intrigeri over 2 years ago

  • Priority changed from High to Normal

#9 Updated by intrigeri over 2 years ago

  • Assignee deleted (intrigeri)

Also available in: Atom PDF