Project

General

Profile

Bug #12246

Untranslatable parts of documentation due to inline errors

Added by xin over 2 years ago. Updated over 1 year ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Installation
Target version:
-
Start date:
02/17/2017
Due date:
% Done:

0%

Feature Branch:
Type of work:
End-user documentation
Blueprint:
Starter:
Affected tool:
Installation Assistant

Description

In french we can't have two pages completely translated (it should be the same for other languages).
When we had .fr at the end of inline link, the page show strange things and the related part become incomprehensible after rebuild.

For this two cases, they have an inline in the inline:

Do you think it's possible to change pages structure to avoid this? It was two important parts who need to be translated!


Related issues

Related to Tails - Bug #13341: Avoid use of inline in doc/first_steps/upgrade Resolved 07/01/2017
Duplicates Tails - Bug #6907: ikiwiki po plugin does not play well with inline directives Resolved 12/03/2018 03/12/2019

History

#1 Updated by xin over 2 years ago

  • Related to Bug #6907: ikiwiki po plugin does not play well with inline directives added

#3 Updated by xin over 2 years ago

  • Related to Bug #13341: Avoid use of inline in doc/first_steps/upgrade added

#4 Updated by xin about 2 years ago

  • Description updated (diff)

#5 Updated by xin almost 2 years ago

  • Description updated (diff)

#6 Updated by emmapeel over 1 year ago

With Weblate able to spread the translations to other files, maybe we don't need to be so overjealous when 'duplicating information', as translators will only need to translate once. YOTO (You Only Translate Once).

#7 Updated by emmapeel over 1 year ago

  • Blocks Feature #15411: Core work 2018Q2 → 2018Q3: Technical writing added

#8 Updated by sajolida over 1 year ago

  • Assignee changed from sajolida to xin
  • QA Check set to Info Needed

xin: Can you confirm that this ticket is a duplicate of #6907?

#9 Updated by sajolida over 1 year ago

  • Related to deleted (Bug #6907: ikiwiki po plugin does not play well with inline directives)

#10 Updated by sajolida over 1 year ago

  • Duplicates Bug #6907: ikiwiki po plugin does not play well with inline directives added

#11 Updated by sajolida over 1 year ago

If so it can't be part of #15411.

#12 Updated by sajolida over 1 year ago

  • Blocks deleted (Feature #15411: Core work 2018Q2 → 2018Q3: Technical writing)

#13 Updated by xin over 1 year ago

  • Assignee changed from xin to sajolida

sajolida wrote:

xin: Can you confirm that this ticket is a duplicate of #6907?

#6907 and #12246 are about the same problem but for me #6907 is about fixing PO plugin and this ticket is about changing page structure to workaround the bug (recent proposal is to remove mac_startup_disks.inline and duplicate its content to workaround the bug in install/mac/usb and install/mac/dvd).

I don't know if it can be different tickets.

#14 Updated by sajolida over 1 year ago

  • Status changed from Confirmed to Duplicate
  • Assignee deleted (sajolida)
  • QA Check deleted (Info Needed)
  1. In 2018 we'll drop the need for two different restart thanks to USB images.
  2. We now have a reproducer for #6907.

So I think we should put our energy elsewhere than into restructuring these installation instructions.

Also available in: Atom PDF