Project

General

Profile

Bug #12243

icedove/gnupg trigger infinite loop related to apparmor

Added by alant over 2 years ago. Updated over 2 years ago.

Status:
Rejected
Priority:
Elevated
Assignee:
-
Category:
-
Target version:
Start date:
02/16/2017
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Email Client

Description

I had icedove using 100% CPU, closed it, then gpg2 is using 100% CPU too. Logs are flooded by apparmpor messages:

Feb 16 08:51:35 amnesia audit[26260]: AVC apparmor="DENIED" operation="link" profile="icedove//gpg" name="/home/amnesia/.gnupg/gnupg_spawn_agent_sentinel.lock" pid=26260 comm="gpg2" requested_mask="l" denied_mask="l" suid=1000 ouid=1000 target="/home/amnesia/.gnupg/.#lk0x0000556d1b224ba0.amnesia.26260" 
Feb 16 08:51:35 amnesia audit[26260]: AVC apparmor="DENIED" operation="link" profile="icedove//gpg" name="/homeamnesia/.gnupg/gnupg_spawn_agent_sentinel.lock" pid=26260 comm="gpg2" requested_mask="l" denied_mask="l" fsuid=1000 ouid=1000 target="/home/amnesia/.gnupg/.#lk0x0000556d1b224ba0.amnesia.26260" 
Feb 16 08:51:35 amnesia audit[26260]: AVC apparmor="DENIED" operation="link" profile="icedove//gpg" name="/homeamnesia/.gnupg/gnupg_spawn_agent_sentinel.lock" pid=26260 comm="gpg2" requested_mask="l" denied_mask="l" fsuid=1000 ouid=1000 target="/home/amnesia/.gnupg/.#lk0x0000556d1b224ba0.amnesia.26260" 

[...]

Feb 16 08:52:06 amnesia openpgp-applet.desktop[3068]: Deep recursion on anonymous subroutine at /usr/lib/x86_64-linux-gnu/perl5/5.24/Glib/Object/Introspection.pm line 67, <DATA> line 1.
Feb 16 08:52:06 amnesia openpgp-applet.desktop[3068]: *** unhandled exception in callback:
Feb 16 08:52:06 amnesia openpgp-applet.desktop[3068]: ***   Deep recursion on subroutine "main::handle_clipboard_owner_change" at /usr/bin/openpgp-applet line 219, <DATA> line 1.
Feb 16 08:52:06 amnesia openpgp-applet.desktop[3068]: ***  ignoring at /usr/lib/x86_64-linux-gnu/perl5/5.24/Glib/Object/Introspection.pm line 67, <DATA> line 1.
Feb 16 08:52:06 amnesia openpgp-applet.desktop[3068]: Deep recursion on anonymous subroutine at /usr/lib/x86_64-linux-gnu/perl5/5.24/Glib/Object/Introspection.pm line 67, <DATA> line 1.
Feb 16 08:52:06 amnesia openpgp-applet.desktop[3068]: *** unhandled exception in callback:
Feb 16 08:52:06 amnesia openpgp-applet.desktop[3068]: ***   Deep recursion on subroutine "main::handle_clipboard_owner_change" at /usr/bin/openpgp-applet line 219, <DATA> line 1.
Feb 16 08:52:06 amnesia openpgp-applet.desktop[3068]: ***  ignoring at /usr/lib/x86_64-linux-gnu/perl5/5.24/Glib/Object/Introspection.pm line 67, <DATA> line 1.

[...]

Feb 16 08:52:11 amnesia kernel: audit_printk_skb: 193584 callbacks suppressed
Feb 16 08:52:11 amnesia kernel: audit: type=1400 audit(1487235131.128:6407132): apparmor="DENIED" operation="link" profile="icedove//gpg" name="/home/amnesia/.gnupg/gnupg_spawn_agent_sentinel.lock" pid=25520 comm="gpg2" requested_mask="l" denied_mask="l" fsuid=1000 ouid=1000 target="/home/amnesia/.gnupg/.#lk0x000055cc80cb0120.amnesia.25520" 
Feb 16 08:52:11 amnesia kernel: audit: type=1400 audit(1487235131.128:6407133): apparmor="DENIED" operation="link" profile="icedove//gpg" name="/home/amnesia/.gnupg/gnupg_spawn_agent_sentinel.lock" pid=25520 comm="gpg2" requested_mask="l" denied_mask="l" fsuid=1000 ouid=1000 target="/home/amnesia/.gnupg/.#lk0x000055cc80cb0120.amnesia.25520" 
Feb 16 08:52:11 amnesia kernel: audit: type=1400 audit(1487235131.128:6407134): apparmor="DENIED" operation="link" profile="icedove//gpg" name="/home/amnesia/.gnupg/gnupg_spawn_agent_sentinel.lock" pid=25520 comm="gpg2" requested_mask="l" denied_mask="l" fsuid=1000 ouid=1000 target="/home/amnesia/.gnupg/.#lk0x000055cc80cb0120.amnesia.25520" 
Feb 16 08:52:11 amnesia kernel: audit: type=1400 audit(1487235131.128:6407135): apparmor="DENIED" operation="link" profile="icedove//gpg" name="/home/amnesia/.gnupg/gnupg_spawn_agent_sentinel.lock" pid=25520 comm="gpg2" requested_mask="l" denied_mask="l" fsuid=1000 ouid=1000 target="/home/amnesia/.gnupg/.#lk0x000055cc80cb0120.amnesia.25520" 

History

#1 Updated by intrigeri over 2 years ago

  • Assignee set to u
  • Affected tool set to Email Client

Looks like the AppArmor profile lacks a line about that file. u, do you want to take care of it, e.g. during the next Stretch sprint? Otherwise, fine, I can handle it as part of my Foundations Team work.

#2 Updated by intrigeri over 2 years ago

  • Assignee changed from u to alant
  • QA Check set to Info Needed

Actually, Alan had icedove listed in his additional software packages, and as a result Icedove was upgraded to 1:45.6.0-2 during his Tails session. This might explain the problem he's seen => Alan, please reassign to me or U.if you can reproduce this problem without this unsupported upgrade.

#3 Updated by u over 2 years ago

  • Assignee changed from alant to u

#4 Updated by u over 2 years ago

  • Priority changed from Normal to Elevated

#5 Updated by alant over 2 years ago

  • Status changed from Confirmed to Rejected
  • Assignee deleted (u)
  • QA Check deleted (Info Needed)

I cannot reproduce this issue. I'm rejecting it.

Also available in: Atom PDF