Project

General

Profile

Feature #12206

Ensure 3.0~beta1 can be incrementally upgraded to 3.0~beta2, etc.

Added by intrigeri almost 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
-
Target version:
Start date:
02/01/2017
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Upgrader

Description

I think the nicest way to do that is to configure /etc/os-release so that the alpha update channel is used. And we'll revert that in 3.0 final.

To avoid breaking the test suite, an UDF for 1.0~test / amd64 should be added to the alpha channel.


Related issues

Blocks Tails - Feature #12195: Ask contributors to upgrade to 3.0~betaN Resolved 01/30/2017
Blocks Tails - Feature #12207: Announce Tails 3.0~beta1 Resolved 02/01/2017

Associated revisions

Revision ecfceac5 (diff)
Added by intrigeri almost 3 years ago

Upgrader: use the alpha channel when the next version will be an alpha, beta, or RC.

The basic idea here is to make it easy for users of 3.0~betaN to upgrade to the
next beta or RC, without having to type any command-line, and without having to
create UDFs for these upgrade paths on the "stable" update channel (that would
feel wrong, wouldn't it?).

Bonus: once this is in place, more generally we'll be able to update our release
process doc+scripts to stop creating meaningless "stable" channel upgrades for
RCs, such as upgrade/v1/Tails/2.10~rc1/i386/stable/upgrades.yml, that we have
been needing so far since our RCs thought they were using the "stable"
update channel.

refs: #12206

Revision 120bd775 (diff)
Added by anonym almost 3 years ago

Also publish the incremental upgrade used in the test suite on the alpha channel.

Refs: #12206

History

#1 Updated by intrigeri almost 3 years ago

  • Blocks Feature #12195: Ask contributors to upgrade to 3.0~betaN added

#2 Updated by intrigeri almost 3 years ago

  • Description updated (diff)

#3 Updated by intrigeri almost 3 years ago

  • Assignee changed from intrigeri to anonym

(for the test suite bits)

#4 Updated by intrigeri almost 3 years ago

#5 Updated by anonym almost 3 years ago

  • Status changed from Confirmed to Resolved
  • Assignee deleted (anonym)

Also available in: Atom PDF