Project

General

Profile

Bug #12203

Thunderbird account setup wizard fails with "Programming bug. Assertion failed, see log." when using Manual config

Added by intrigeri almost 3 years ago. Updated 4 months ago.

Status:
Confirmed
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
01/31/2017
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Email Client

Description

  1. start Tails 2.10
  2. set up persistence, enable Icedove feature
  3. reboot, unlock persistence
  4. start Thunderbird
  5. pick some email address and password
  6. it guesses POP3
  7. I click "Manual config" to inspect what settings were guessed
  8. I click re-test (as the "done" button is grayed out / disabled)
  9. I click "Done"
  10. a dialog opens that says "Programming bug. Assertion failed, see log."

I don't remember if I clicked "manual config" or if it was opened already, nor whether there were radio buttons to select IMAP instead of POP. Will retry.


Related issues

Related to Tails - Bug #15788: Rethink our patches with Thunderbird 60 Resolved 08/14/2018

History

#1 Updated by intrigeri almost 3 years ago

  • Subject changed from Icedove account setup wizard fails with "Programming bug. Assertion failed, see log." to Icedove account setup wizard fails with "Programming bug. Assertion failed, see log." when using Manual config
  • Description updated (diff)
  • Status changed from New to Confirmed
  • Assignee changed from intrigeri to anonym
  • Target version deleted (Tails_2.11)
  • Type of work changed from Test to Code

Simplified my test case.

#2 Updated by u almost 2 years ago

We should retest if this is still present in Tails 3.4 or later.

#3 Updated by u almost 2 years ago

  • Subject changed from Icedove account setup wizard fails with "Programming bug. Assertion failed, see log." when using Manual config to Thunderbird account setup wizard fails with "Programming bug. Assertion failed, see log." when using Manual config
  • Description updated (diff)

#4 Updated by u about 1 year ago

  • Assignee changed from anonym to intrigeri

I'm not sure how you test Thunderbird 60 in Tails, but it might be useful to test this scenario with the patches.

#5 Updated by u about 1 year ago

  • Related to Bug #15788: Rethink our patches with Thunderbird 60 added

#6 Updated by intrigeri about 1 year ago

  • Assignee changed from intrigeri to anonym

I've seen this bug again with TB 60.

#7 Updated by mercedes508 about 1 year ago

intrigeri wrote:

I've seen this bug again with TB 60.

An user experiencing this issue sent us an email today. If you need me to ask for details.

#8 Updated by intrigeri about 1 year ago

An user experiencing this issue sent us an email today.

ACK. I've seen it too.

If you need me to ask for details.

At this stage, given we can reproduce it ourselves, I don't think that'll be needed. But please let us know if that's more widespread than 1 user.

#9 Updated by yawnbox 4 months ago

I am reproducing this in Tails 3.15

Also available in: Atom PDF