Project

General

Profile

Bug #12200

Feature #5464: Revamp Greeter interface

Feature #8230: Greeter revamp: Phase 1

The Greeter's release process is broken: POTFILES.in lists non-existing file

Added by intrigeri almost 3 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Internationalization
Target version:
Start date:
01/31/2017
Due date:
% Done:

100%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Greeter

Description

... and there are no instructions to generate it:

./setup.py build_i18n                                                         
running build_i18n
intltool-update -p -g tails-greeter
xgettext: error while opening "../data/greeter.ui.h" for reading: No such file or directory
ERROR: xgettext failed to generate PO template file. Please consult
       error message above if there is any.
error: command 'intltool-update' failed with exit status 1

I assume that commit c3ee13f91e5ef25b0b10e4353538e4cdcc781afc was correct, but then wiki/src/contribute/release_process/tails-greeter.mdwn needs to be updated in the feature/stretch branch so that one can follow it without having to guess what additional steps are required.

Thanks in advance!

History

#1 Updated by intrigeri almost 3 years ago

Looks like one must run ./setup.py build, then follow "Update POT and PO files", then git clean -fdx to clean things up. Possibly ./setup.py build has some dependencies that should be documented. In some other release process docs we have, we use mk-build-deps to install the build-deps on the system; this might be helpful here too.

#2 Updated by alant over 2 years ago

  • Status changed from Confirmed to 11
  • % Done changed from 0 to 100

This is fixed in bugfix/12200-gtkbuilderi18n. The build of GtkBuilder headers is now a dependency of build_i18n.

#3 Updated by alant over 2 years ago

  • Status changed from 11 to In Progress
  • % Done changed from 100 to 50
  • QA Check set to Ready for QA
  • Type of work changed from Contributors documentation to Code

#4 Updated by alant over 2 years ago

  • Assignee changed from alant to intrigeri

#5 Updated by intrigeri over 2 years ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (intrigeri)
  • % Done changed from 50 to 100
  • QA Check changed from Ready for QA to Pass

works for me, thanks!

Also available in: Atom PDF