Project

General

Profile

Bug #12197

Confusing UI/log when trying to use obfs4 bridges / impossible to use obfs4

Added by camelcross over 2 years ago. Updated almost 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
Tor configuration
Target version:
-
Start date:
01/31/2017
Due date:
% Done:

0%

Feature Branch:
Type of work:
User interface design
Blueprint:
Starter:
Affected tool:
Tor Launcher

Description

i have a couple of decades programming background and have been using privacy tech.

i tried to set up Tails to a friend in Kazahstan, where Tor is blocked, therefore i needed obfs bridges.

it looks like obfs4 bridge lines are simply not supported by the version of Tor that is delivered with Tails.

i've been staring at the log and searching the web for hours until i found a hint that maybe i should try obfs3 bridges, which finally worked.

please make sure that there's an easier way to get some more explicit feedback if this is the case.


Related issues

Related to Tails - Bug #9268: obfs4 bridges often don't work (maybe MTU?) Confirmed 04/21/2015

History

#1 Updated by elouann over 2 years ago

  • Assignee set to camelcross
  • QA Check set to Info Needed

Hi camelcross, and thank you for you feedback

According to the ticket #9268 , some work is being done to improve support of obfs4 bridges in Tails.

Regarding the "easier way to get some more explicit feedback if this is the case", could you please be more explicit?

Thank you,
cheers

#2 Updated by camelcross over 2 years ago

Regarding the "easier way to get some more explicit feedback if this is the case", could you please be more explicit?

first of all, i'm assuming here that obfs4 is simply not supported, as opposed to just not working because of some integration bug. if this is not the case, then it pretty much invalidates my entire ticket.

and i don't know what UI mechanisms are available for posting a feedback to the user.

with that in mind:
  • i was staring at the tor log and i didn't see any hints that i should try obfs3 bridges instead of obfs4.
  • it would be nice if there was an easy way to inspect the tor log, especially if there was some visual feedback (in the status bar?) when there are errors printed in the log.

#3 Updated by intrigeri over 2 years ago

  • Assignee changed from camelcross to elouann

first of all, i'm assuming here that obfs4 is simply not supported,

It is supported and used by a number of users. Sadly, no Tails developer was able to reproduce issues reported by some users about it :/

I'll let elouann finish triaging this ticket.

#4 Updated by u about 2 years ago

  • Related to Bug #9268: obfs4 bridges often don't work (maybe MTU?) added

#5 Updated by u about 2 years ago

  • Assignee changed from elouann to camelcross

@camelcross, I know this ticket is already pretty old, but could you provide the bridges that you tried? It might be that they were temporarily blocked. If possible, and you can still reproduce the issue, can you provide the tor log?

#6 Updated by u about 2 years ago

  • Subject changed from confusing UI/log when trying to use obfs4 bridges to Confusing UI/log when trying to use obfs4 bridges / impossible to use obfs4

#7 Updated by tailshark about 2 years ago

I've been using bridges pretty extensively myself in a jurisdiction that doesn't actually require them (I have concerns about Tor consensus tampering and it makes firewall whitelisting easier).

When I go to rotate my bridges with a candidate list of about... 20 or so bridges selected at random with unknown transport protocols... only 3 or 4 of the bridges will acually work. What stands out to me is I'll have another 6 or so that report back in OnionCircuits showing their name but will refuse to actually build any outbound circuits. In one case I had a bridge that would build circuits (many complete circuits with all 3 hops) but refuse to transmit any actual data which jammed my data flows entirely and I had to eliminate that particular bridge and restart the service to get data moving again.

I've been keeping an eye on these tickets passively for awhile now and it's looking like they're needing a little helping along. Since I use bridges every day and I'm not in a country that (as far as I know!) interferes with their connectivity I'll be happy to check the logs and report back the next time one of them gives me trouble.

Any place I should watch for other than /var/log/tor/log and potentially dmesg?

#8 Updated by goupille almost 2 years ago

  • Status changed from New to Duplicate

seems a lot like #9268

Also available in: Atom PDF