Project

General

Profile

Bug #12190

OpenPGP applet public key list includes 21 empty key lines

Added by intrigeri about 3 years ago. Updated about 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
01/30/2017
Due date:
% Done:

10%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:
OpenPGP Applet

Description

  1. copy some text so the clipboard is not empty
  2. OpenPGP applet icon -> Encrypt clipboard with public key
  3. if you have a small number of keys, the "Choose keys" window lists the expected 6 keys + 21 empty key lines
  4. if you have a large number of keys, no empty lines but the tooltip is all wrong (doesn't match the actual raw)

Related issues

Related to Tails - Feature #13602: OpenPGP Applet: rewrite key selection interface Duplicate 08/08/2017

History

#1 Updated by intrigeri about 3 years ago

Next step: try to reproduce on more recent feature/stretch or feature/stretch-unfrozen, and if it still happens there, try to reproduce on current Debian testing/sid.

#2 Updated by anonym about 3 years ago

  • Target version changed from Tails_3.0 to Tails_2.11

I can reproduce this in Tails 2.10. The empty entries appear when I hover the mouse over the other entries in the list, and I count 22 of them when it stops.

IMHO, the next step is to reproduce on Debian Jessie.

#3 Updated by intrigeri about 3 years ago

  • Assignee set to nodens

I can reproduce this in Tails 2.10. The empty entries appear when I hover the mouse over the other entries in the list, and I count 22 of them when it stops.

Thanks!

IMO that's not severe enough to be worth prioritizing this much: it can certainly wait a few months to be fixed, and we (foundations team) probably have higher priority bugs to tackle. So personally I would postpone this to 2.12 or 3.0 unless nodens comes up with a quick fix.

#4 Updated by intrigeri about 3 years ago

  • Target version changed from Tails_2.11 to Tails_2.12

#5 Updated by intrigeri almost 3 years ago

  • Target version deleted (Tails_2.12)

(On our side it can wait until there's a fix upstream, and I doubt nodens uses "Target version" to organize his work.)

#6 Updated by Anonymous almost 3 years ago

I confirm this is still present in 3.0.

Can you, nodens, please test this on current Debian sid and report back?

#7 Updated by Anonymous almost 3 years ago

  • QA Check set to Info Needed
  • Type of work changed from Code to Test

#8 Updated by nodens over 2 years ago

  • % Done changed from 0 to 10
  • QA Check changed from Info Needed to Dev Needed
  • Type of work changed from Test to Code

So it is still here in current Sid.
The problem seems to lie in the Gtk3::SimpleList module, that apparently doesn't behave properly wrt Gtk::TreeView.
Another part of the issue is that the tooltip is wrong when you have a large number of keys (but doesn't add any empty lines).

I'll see if I find a simplefix, or maybe it's time to rewrite this part completely, using the complete Gtk::TreeView implementation (which could actually enable us to do some nicer stuff, UI-Wise).

#9 Updated by nodens over 2 years ago

  • Description updated (diff)

#10 Updated by nodens over 2 years ago

  • Related to Feature #13602: OpenPGP Applet: rewrite key selection interface added

#11 Updated by nodens about 2 years ago

  • Status changed from Confirmed to Resolved

Hi,

OpenPGP applet is moving to its new home on https://salsa.debian.org/openpgp-applet-team/openpgp-applet

This issue has been duplicated upstream: https://salsa.debian.org/openpgp-applet-team/openpgp-applet/issues/7

I'm closing this one. Feel free to comment on the upstream link!

You will need an account on Salsa. If you don't have one already, you can create one on https://signup.salsa.debian.org/.

Cheers!

#12 Updated by intrigeri about 2 years ago

  • Status changed from Resolved to Duplicate

Also available in: Atom PDF