Project

General

Profile

Feature #12180

Feature #12035: Donation campaign 2017

Write a blog post "why regular donations are better"

Added by BitingBird almost 3 years ago. Updated over 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
Fundraising
Target version:
-
Start date:
01/26/2017
Due date:
% Done:

0%

Feature Branch:
Type of work:
Communicate
Blueprint:
Starter:
Affected tool:

Description

We didn't write about this in 2016, could be interesting either in the middle of 2017 or for the next donation campaign.

That could probably be inspired by similar messages from riseup, for example.

History

#1 Updated by intrigeri almost 3 years ago

Sounds like a good idea to me, thanks!

Nitpicking: maybe s/monthly/recurring/, as we also offer a "yearly" option which is just as good for our needs, I think.

#2 Updated by u over 2 years ago

  • QA Check set to Info Needed

May somebody provide such a similar message from Riseup?

#3 Updated by u over 2 years ago

  • Assignee set to BitingBird

Assigning to BitingBird who brought this up. Please reassign to me later on.

#4 Updated by BitingBird over 2 years ago

  • Assignee deleted (BitingBird)
  • QA Check deleted (Info Needed)

I had the idea, and I think it would bring something, but I don't volunteer to do it. Here is their email I was thinking about:

"Riseup has a lot of users and groups who give us monthly donations. Yay! This is huge for us because we’re able to plan for our future collective work with a firmer idea of what we’ll be able to fund.

What are those plans? They’re evolving, and always involve implementing more secure protocols, expanding our services worldwide, and offering a growing number of secure and surveillance-free internet communication tools.

If you can, if you’re able, we’d love for you to sign up for monthly donations at whatever level you can ($5 = so awesome. $10 = so awesome. More money = so awesome.)" in https://we.riseup.net/riseuphelp+en/newsletter-2012-4#invited-to-the-money-dance

#5 Updated by u over 2 years ago

  • Assignee set to u

#6 Updated by u over 2 years ago

  • Subject changed from Write a blog post "why monthly donations are better" to Write a blog post "why regular donations are better"

#7 Updated by u over 2 years ago

  • Status changed from Confirmed to Duplicate

I will merge this into my 3rd post about our future plans. Thus closing this ticket as duplicate.

Also available in: Atom PDF