Project

General

Profile

Feature #12175

Add optional pause() notification feature to the test suite

Added by anonym over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Test suite
Target version:
Start date:
01/25/2017
Due date:
% Done:

100%

Feature Branch:
test/12175-pause-notification
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

I want something that can run an arbitrary shell (set via the configuration system) command when pause() is called, e.g. on failure when --interactive-debugging is used. This will be pretty useful when multitasking with long test suite runs, so you immediately are notified when a test fails (or when you reached a temporary pause() breakpoint).

Associated revisions

Revision 9bdf05e4 (diff)
Added by anonym over 2 years ago

Add optional pause() notification feature to the test suite.

It will run an arbitrary shell command when pause() is called, e.g. on
failure when --interactive-debugging is used. This is pretty useful
when multitasking with long test suite runs, so you immediately are
notified when a test fails (or when you reached a temporary pause()
breakpoint).

Will-fix: #12175

Revision b0ba5018
Added by anonym over 2 years ago

Merge remote-tracking branch 'origin/test/12175-pause-notification' into stable

Fix-committed: #12175

History

#1 Updated by anonym over 2 years ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from anonym to intrigeri
  • % Done changed from 0 to 50
  • QA Check set to Ready for QA
  • Feature Branch set to test/12175-pause-notification

#2 Updated by intrigeri over 2 years ago

  • Assignee changed from intrigeri to anonym
  • % Done changed from 50 to 60
  • QA Check changed from Ready for QA to Dev Needed

Good idea!

  • Typo in interactive-debuggin and INTERACTIVE_DEBUGGIN
  • Do we really need this level of customizability, i.e. an arbitrary command that everyone must craft for themselves? E.g. I would be perfectly happy with a desktop notification. So if e.g. notify-send works for you too, maybe we can instead settle on that? Now I won't nitpick endlessly here, I'm fine with what you implemented already, and would probably have merged it as a first step if there wasn't the typo.

#3 Updated by anonym over 2 years ago

  • Assignee changed from anonym to intrigeri
  • QA Check changed from Dev Needed to Ready for QA

intrigeri wrote:

Good idea!

  • Typo in interactive-debuggin and INTERACTIVE_DEBUGGIN

Thanks, fixed!

  • Do we really need this level of customizability, i.e. an arbitrary command that everyone must craft for themselves? E.g. I would be perfectly happy with a desktop notification. So if e.g. notify-send works for you too, maybe we can instead settle on that? Now I won't nitpick endlessly here, I'm fine with what you implemented already, and would probably have merged it as a first step if there wasn't the typo.

Sounds like the GNOME in you speaking! :) I personally love this level of customizability, and would not be satisfied with notify-send since I won't hear it (and I refuse to configure notifications to make a sounds in general since that will drive me crazy). I very often start extensive test suite runs with --interactive-debugging, go AFK, and have to frequently go back to the computer constantly to check if there was an error that made the run pause. I hate the "frequently go[ing] back" part. With this feature as-is I can point it to an "alarm" script I have that ensures a loud sound will be played unmuted and at max volume.

#4 Updated by anonym over 2 years ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (intrigeri)
  • % Done changed from 60 to 100
  • QA Check changed from Ready for QA to Pass

intrigeri gave me the go-ahead to merge this myself.

#5 Updated by anonym over 2 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF