Project

General

Profile

Feature #12155

Feature #12035: Donation campaign 2017

Add "Purpose of transfer" to the donation page bank transfer section

Added by u about 3 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
01/19/2017
Due date:
% Done:

100%

Feature Branch:
451f:tails/feature/12155+transfer_purpose
Type of work:
Research
Blueprint:
Starter:
Affected tool:

Description

Suggested by sycamoreone on the testers mailinglist:

some feedback from actual donors (before the campaign ends): For a bank
transfer (like to Zwiebelfreunde e.V.) people are usually given a
"Purpose of transfer" or "Verwendungszweck". It is not obvious that the
purpose of the transfer is encoded into the IBAN so people are confused
and probably reluctant to just transfer the money.

For larger donations it would also be interesting to get information
about the possibility of a tax refund (because Zwiebelfreunde is
registered as a not-for-profit in Germany). I think the old donation
pages mentioned that one needs to contact Zwiebelfreunde for this.

I agree, that if we keep the new donation page, which we actually could, we should add this information back there.


Related issues

Related to Tails - Feature #12036: Clarify requirements and process to get donation receipts Resolved 12/16/2016

Associated revisions

Revision 94b91825 (diff)
Added by u over 2 years ago

Add purpose of transfer.

will-fix: #12155

History

#1 Updated by u about 3 years ago

  • QA Check set to Info Needed

What do you think?

#2 Updated by spriver about 3 years ago

I like the idea of sycamoreone wrt. the transfer purpose when donating via a bank account to Zwiebelfreunde e.V.

For larger donations it would also be interesting to get information
about the possibility of a tax refund (because Zwiebelfreunde is
registered as a not-for-profit in Germany). I think the old donation
pages mentioned that one needs to contact Zwiebelfreunde for this.

Is #12036 about that?

#3 Updated by u about 3 years ago

Thanks spriver. Yes it's partly about the same issue. However, in the page we link to https://www.torservers.net/wiki/verein/spendenbescheinigung this talks only about the spendenbescheinigung and sycamoreone's proposal was also about adding a "verwendungszweck". I will try to draft something quickly for these pages as a text.

#4 Updated by sajolida almost 3 years ago

  • Status changed from New to Confirmed
  • Assignee deleted (sajolida)
  • Parent task set to #12035
  • QA Check deleted (Info Needed)
  • Type of work changed from End-user documentation to Research

I'm not volunteering to tackle this so let's put this as a subtask for next year's campaign and see what happens.

I followed up on sycamore one's email there: https://mailman.boum.org/pipermail/tails-testers/2017-March/000676.html.

I still think that the title of this ticket is too generic but I feel lazy to either some the issues right away or make it more specific.

#5 Updated by u almost 3 years ago

  • Assignee set to u

I want to look into this.

#6 Updated by u almost 3 years ago

My proposal here is to add "Purpose of transfer: Donation to Tails" to the section "Bank Transfer". This seems necessary for european bank transfers i've seen at least.

#7 Updated by u almost 3 years ago

  • Related to Feature #12036: Clarify requirements and process to get donation receipts added

#8 Updated by u almost 3 years ago

  • Subject changed from Donation page improvements to Add "Purpose of transfer" to the donation page bank transfer section

Renaming this ticket to what it is about.

The Spendenbescheinigung / receipt of donation part is handled by https://labs.riseup.net/code/issues/12036

#9 Updated by u over 2 years ago

  • Assignee changed from u to sajolida
  • QA Check set to Ready for QA
  • Feature Branch set to 451f:tails/feature/12155+transfer_purpose

I simply added one line to donate.html.
Please review and merge.

#10 Updated by sajolida over 2 years ago

  • Target version set to Tails_3.1

#11 Updated by sajolida over 2 years ago

  • Status changed from Confirmed to Resolved
  • Assignee deleted (sajolida)
  • QA Check deleted (Ready for QA)

That was easy :)

#12 Updated by intrigeri over 2 years ago

  • Target version changed from Tails_3.1 to Tails_3.0.1

#13 Updated by BitingBird over 2 years ago

  • % Done changed from 0 to 100

Also available in: Atom PDF