Project

General

Profile

Bug #12141

UEFI boot on QEMU is broken since 2.10~rc1

Added by anonym almost 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Virtualization
Target version:
Start date:
01/13/2017
Due date:
% Done:

100%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

At least when running this scenario on my system (Debian Sid), Plymouth doesn't work, and Xorg doesn't start => failure. Booting from UEFI on baremetal works for me, though.


Related issues

Related to Tails - Bug #11583: UEFI boot tests fail on Jenkins Resolved 07/21/2016

History

#1 Updated by intrigeri almost 3 years ago

  • Assignee set to anonym

It's not realistic to have 2.10 tickets without assignee, and this is our plate, so either you take care of it, or you ask me to :)

#2 Updated by anonym almost 3 years ago

There was a new ovmf in Sid in December, version 0~20161202.7bbe0b3e-1, so I tried downgrading to the previous version, 0~20160813.de74668f-2, but no luck.

#3 Updated by anonym almost 3 years ago

  • Assignee changed from anonym to intrigeri
  • QA Check set to Info Needed

Can you reproduce this on your Sid system?

#4 Updated by intrigeri almost 3 years ago

Sure, will try to! (but not with a 2.10 deadline)

#5 Updated by anonym almost 3 years ago

  • Target version changed from Tails 2.10 to Tails_2.11

intrigeri wrote:

Sure, will try to! (but not with a 2.10 deadline)

Ok, let's ignore this for now and look at it during the next cycle then. I cannot reproduce on bare metal, so I'm fairly sure this is due to some change on the host system (specifically when running Debian Sid) and hence nothing critical for our users. Please let me know if you think I'm wrong.

#6 Updated by intrigeri almost 3 years ago

  • Subject changed from Scenario 'Booting Tails from a USB drive in UEFI mode' is broken on Tails 2.10~rc1 to UEFI boot on QEMU is broken since 2.10~rc1
  • Category changed from Test suite to Virtualization
  • Status changed from Confirmed to In Progress
  • Assignee changed from intrigeri to anonym
  • % Done changed from 0 to 10

Reproduced with 2.10 ISO on almost up-to-date sid. But on the same system it works fine with the 2.9.1 ISO. So it's a regression in the virtualization support of Tails itself, not a regression in our test suite per-se. If I had to guess, I would blame either the (many) changes in the qxl driver in Linux v4.7.8..v4.8.11, or the libdrm upgrade (2.4.70 → 2.4.74), or the mesa upgrade (11.1.3 → 12.0.4).

So, there are two aspects to this:

  • users running Tails in QEMU: I wonder why they would bother booting in UEFI mode, the default is legacy boot, which works fine, so I would not bother about them;
  • developers running our test suite:
    • the corresponding scenario is marked as fragile, so Jenkins is not affected
    • Jessie host system: is this use case affected at all? with 2.x, with 3.x? if only 2.x is affected, I say forget it
    • testing/sid host system: if this only affects Tails 2.x ISO images, I say forget it; does it affect Tails 3.x ISO images?

#7 Updated by anonym almost 3 years ago

  • Related to Bug #11583: UEFI boot tests fail on Jenkins added

#8 Updated by anonym almost 3 years ago

I've refreshed #11583's test/11583-uefi-boot-is-fragile branch so this scenario will run on Jenkins (i.e. Debian Jessie). Let's see if it works (my hopes are not high after skimming through #11583). I'll answer your comment when I have results.

#9 Updated by anonym almost 3 years ago

  • Status changed from In Progress to Resolved
  • Assignee changed from anonym to intrigeri
  • Target version changed from Tails_2.11 to Tails_3.0
  • % Done changed from 10 to 100
  • QA Check changed from Info Needed to Pass

intrigeri wrote:

  • users running Tails in QEMU: I wonder why they would bother booting in UEFI mode, the default is legacy boot, which works fine, so I would not bother about them;

Agreed.

  • developers running our test suite:

To be clear, this was my only concern.

  • the corresponding scenario is marked as fragile, so Jenkins is not affected
  • Jessie host system: is this use case affected at all? with 2.x, with 3.x? if only 2.x is affected, I say forget it

No clue. The only Jessie hosts I run the test suite on is Jenkins' isobuilders, and on them UEFI boot doesn't work for other reasons (#11583).

  • testing/sid host system: if this only affects Tails 2.x ISO images, I say forget it; does it affect Tails 3.x ISO images?

Indeed, it seems 3.x is not affected. Cool! => closing.

#10 Updated by anonym almost 3 years ago

(Preemptive answer to intrigeri: since this automated test will fail for all remaining 2.x releases, whoever is responsible to run the automated test suite will realize that the UEFI boot test must be done manually, so we don't have to bother adding it to our manual test suite, imho.)

#11 Updated by intrigeri almost 3 years ago

(Preemptive answer to intrigeri: since this automated test will fail for all
remaining 2.x releases, whoever is responsible to run the automated test suite will
realize that the UEFI boot test must be done manually, so we don't have to bother
adding it to our manual test suite, imho.)

ACK!

Also available in: Atom PDF