Project

General

Profile

Bug #12139

VirtualBox guest modules are missing in Tails 2.10~rc1

Added by anonym almost 3 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Virtualization
Target version:
Start date:
01/13/2017
Due date:
% Done:

100%

Feature Branch:
bugfix/12139-virtualbox-dkms
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

This is a regressions since Tails 2.9.1.

From tails-i386-2.10~rc1.iso.buildlog:

[...]
Loading new virtualbox-guest-5.1.8 DKMS files...
First Installation: checking all kernels...
Building only for 4.8.0-0.bpo.2-amd64
Module build for the currently running kernel was skipped since the
kernel source for this kernel does not seem to be installed.
Compiling and installing a custom udev-watchdog program
[...]

Note that it is not even mentioning the -686 kernel (whose headers package is installed, so it would work).

Even stranger, this does not seem to affect Jenkins: https://jenkins.tails.boum.org/job/build_Tails_ISO_testing/9/ . Could it be due to the new Vagrant basebox (#12081)? I used it when building Tails 2.10~rc1, obviously.

However, I can see that I built other branches using that basebox which did result in the modules being built, but they were all still on Linux 4.7, so perhaps it in combination with the upgrade to Linux 4.8 (#11886)? For the record, then the .buildlog looks like this:

[...]
Loading new virtualbox-guest-5.1.8 DKMS files...
First Installation: checking all kernels...
It is likely that 4.8.0-0.bpo.2-amd64 belongs to a chroot's host
Building initial module for 4.7.0-0.bpo.1-686
Done.

vboxguest:
[... success ...]

Note that it detected the builder VMs kernel (4.8.0-0.bpo.2-amd64). Perhaps there's some bug when the builder VM has the same kernel as the target Tails build?


Related issues

Related to Tails - Feature #12104: Decide whether we can drop DKMS modules support Rejected 01/01/2017

Associated revisions

Revision 5dbe66da (diff)
Added by intrigeri almost 3 years ago

Ensure the VirtualBox guest DKMS modules are built for the kernel we want them for (refs: #12139).

In some situations, depending on the version of the running kernel, the modules
would not be built for the 686 kernel, which is the one that needs the
VirtualBox guest modules.

This commit ensures the VirtualBox guest modules are built and installed
regardless of the how the build environment looks like.

Revision 25fbafbd
Added by anonym almost 3 years ago

Merge remote-tracking branch 'origin/bugfix/12139-virtualbox-dkms' into testing

Fix-committed: #12139

History

#1 Updated by anonym almost 3 years ago

  • Assignee set to intrigeri

I need your expertise!

#2 Updated by anonym almost 3 years ago

anonym wrote:

I need your expertise!

This could be following up on my comment on #12104 and decide that we don't care about VirtualBox support any more.

#3 Updated by cypherpunks almost 3 years ago

+1. It would be useful if DKMS modules can be built on Tails.

```
Setting up virtualbox-dkms (4.3.36-dfsg-1+deb8u1) ...
Loading new virtualbox-4.3.36 DKMS files...
First Installation: checking all kernels...
Building only for 4.6.0-0.bpo.1-amd64
Module build for the currently running kernel was skipped since the
kernel source for this kernel does not seem to be installed.
Setting up virtualbox (4.3.36-dfsg-1+deb8u1) ...
Job for virtualbox.service failed. See 'systemctl status virtualbox.service' and 'journalctl -xn' for details.
invoke-rc.d: initscript virtualbox, action "restart" failed
```

linux-headers-amd64 is installed but that package provides linux-headers-3.16.0-4-amd64. Should DKMS be building against 3.16 headers instead of 4.6?

#4 Updated by anonym almost 3 years ago

cypherpunks wrote:

linux-headers-amd64 is installed but that package provides linux-headers-3.16.0-4-amd64. Should DKMS be building against 3.16 headers instead of 4.6?

No, wou will need the kernel headers from jessie-backports (we already pin it like so) since that is the kernel we use. During build when we run DKMS we make sure to install the correct kernel headers: config/chroot_local-hooks/50-dkms

#5 Updated by intrigeri almost 3 years ago

  • Related to Feature #12104: Decide whether we can drop DKMS modules support added

#6 Updated by intrigeri almost 3 years ago

  • Related to Bug #12014: Tails Installer accessibility: speech does not work added

#7 Updated by intrigeri almost 3 years ago

  • Related to deleted (Bug #12014: Tails Installer accessibility: speech does not work)

#8 Updated by intrigeri almost 3 years ago

FWIW I can reproduce this locally (with the new Vagrant basebox).

#9 Updated by intrigeri almost 3 years ago

  • Category set to Virtualization
  • Status changed from Confirmed to In Progress
  • Assignee changed from intrigeri to anonym
  • % Done changed from 0 to 50
  • QA Check set to Ready for QA
  • Feature Branch set to bugfix/12139-virtualbox-dkms
  • Type of work changed from Research to Code

#10 Updated by anonym almost 3 years ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (anonym)
  • % Done changed from 50 to 100
  • QA Check changed from Ready for QA to Pass

Tested successfully. Cheers!

#11 Updated by anonym over 2 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF