Project

General

Profile

Feature #12134

Feature #9855: Donation campaign 2016

Remove the donation campaign from our website

Added by sajolida almost 3 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Fundraising
Target version:
Start date:
01/12/2017
Due date:
% Done:

0%

Feature Branch:
web/12134-remove-donation-campaign
Type of work:
Website
Blueprint:
Starter:
Affected tool:

Related issues

Related to Tails - Bug #11911: No more navigation breadcrumbs on the website Resolved 11/13/2016

Associated revisions

Revision 1320ee5f (diff)
Added by anonym almost 3 years ago

Adapt tests after the Donation campaign was disabled.

Refs: #12134

Revision 320d9c78 (diff)
Added by intrigeri over 2 years ago

Re-add navigation breadcrumbs (refs: #12134).

On #11911 it was said "They will be back in January once the donation campaign
is over", but apparently this was forgotten.

Partially reverts e54b9f7e7570d199a0729ce93237c400116b614d, that did
two (related) things at a time: I've left the responsive header height part in
case it's still useful.

I've find it too hard to guess if this is going to break the test suite,
so let's see.

Revision 77e40cdb (diff)
Added by intrigeri over 2 years ago

Revert "Responsive header height to deal with wrapping in donation strip"

This reverts the remaining part of
e54b9f7e7570d199a0729ce93237c400116b614d, as our website looks ugly with
the breadcrumbs reintroduced if we keep these CSS bits.

refs: #12134

History

#1 Updated by sajolida almost 3 years ago

  • Assignee changed from sajolida to spriver
  • Feature Branch set to web/12134-remove-donation-campaign

This is one commit and only removing stuff but someone else should check that I'm not forgetting or breaking anything.

spriver: do you want to have a look? Otherwise I'll ask for another volunteer on tails-dev.

#2 Updated by spriver almost 3 years ago

  • Assignee changed from spriver to sajolida
  • QA Check set to Info Needed

I did not find any issue with removing the changes. However, po files, e.g. generated from home.html are still having the strings before removing them in the original file. Do they get removed automatically when the branch's being merged?
Maybe we could avoid having the former strings to be translated getting moved to the bottom of the po files and being commented out there (and only creating bigger files).

#3 Updated by sajolida almost 3 years ago

I did not find any issue with removing the changes.

Thanks for the very quick review!

However, po files, e.g. generated from home.html are still having the strings
before removing them in the original file. Do they get removed
automatically when the branch's being merged? Maybe we could avoid
having the former strings to be translated getting moved to the
bottom of the po files and being commented out there (and only
creating bigger files).

I think that the PO plugin handles this exactly as you are describing.
I didn't run it on my branch before pushing and that's why the PO files
were not updated.

I'll proceed with merging now!

#4 Updated by intrigeri almost 3 years ago

I'll proceed with merging now!

Note that this will break the test suite, so please coordinate with the Foundations Team or release manager, or revert the commit that adjusted the test suite to the donations campaign yourself.

#5 Updated by intrigeri almost 3 years ago

  • Related to Bug #11911: No more navigation breadcrumbs on the website added

#6 Updated by sajolida almost 3 years ago

  • Assignee changed from sajolida to anonym

This seems to be 6e0d777 but it mixes up changes related to the donation campaign (News → Dear Tails user) and unrelated stuff (CupsTestPage.png) so I'm not sure what to do. Reassign to the test suite master.

NB: Now that we have /home the plan is to make it quite dynamic and it will probably change several times a year when doing donation campaign, maybe user surveys, maybe onboarding improvements on this page, etc. How could we combine my desire to be able to adjust this page to your dependency on it for the test suite?

#7 Updated by anonym almost 3 years ago

sajolida wrote:

This seems to be 6e0d777 but it mixes up changes related to the donation campaign (News → Dear Tails user) and unrelated stuff (CupsTestPage.png) so I'm not sure what to do. Reassign to the test suite master.

I fixed it fast enough, so no harm done.

NB: Now that we have /home the plan is to make it quite dynamic and it will probably change several times a year when doing donation campaign, maybe user surveys, maybe onboarding improvements on this page, etc. How could we combine my desire to be able to adjust this page to your dependency on it for the test suite?

I have rewritten the tests so they don't depend much on the exact layout of that page. However, it would help if the page title remained the same forever (i.e. no s/News/Dear Tails user/); is that ok?

#8 Updated by anonym almost 3 years ago

  • Assignee changed from anonym to sajolida

#9 Updated by sajolida almost 3 years ago

  • Assignee changed from sajolida to anonym

You mean <title> and not <span class="title"> I guess?

I added a note about this directly in the page, see 047776b.

Next maybe I can change the <span class="title"> without changing the <title>...

anonym: please confirm which exact HTML bit you depend upon and then I think you can close this ticket.

#10 Updated by anonym almost 3 years ago

  • Assignee changed from anonym to sajolida
  • QA Check deleted (Info Needed)

sajolida wrote:

You mean <title> and not <span class="title"> I guess?

I added a note about this directly in the page, see 047776b.

Next maybe I can change the <span class="title"> without changing the <title>...

anonym: please confirm which exact HTML bit you depend upon and then I think you can close this ticket.

I'm not sure which one since I know very little about HTML/CSS. What I care about is the title that decides the Tor Browser window title. In other words, I want the start page (t.b.o/home) to always make Tor Browser's window title into e.g. "Tails - News - Tor Browser" or "Tails - Home - Tor Browser" or any other never-changing string you are happy with.

#11 Updated by intrigeri almost 3 years ago

  • Status changed from Confirmed to In Progress

Looks like the breadcrumbs are not back. #11911 said "They will be back in January once the donation campaign is over" so I guess it's a small oversight :)

#12 Updated by anonym almost 3 years ago

  • Target version changed from Tails 2.10 to Tails_2.11

#13 Updated by anonym over 2 years ago

  • Target version changed from Tails_2.11 to Tails_2.12

#14 Updated by intrigeri over 2 years ago

intrigeri wrote:

Looks like the breadcrumbs are not back. #11911 said "They will be back in January once the donation campaign is over" so I guess it's a small oversight :)

sajolida, as you might have guessed I care a lot personally about this: in my own experience browsing our website, the lack of breadcrumbs is an important regression. I don't want to pressure you more than I already did, so the best I can do at this point is to propose dealing with this myself. Would you mind if I did?

#15 Updated by sajolida over 2 years ago

Absolutely not.

#16 Updated by intrigeri over 2 years ago

Done, let's see if this breaks the test suite. Next year I'd like us to squash the fundraising campaign "infra" branches + test suite adjustements into very few and easy to find commits before merging them, so we can more easily revert them. But of course, best would be to make our test suite not rely on such details, as anonym started to do :)

#17 Updated by intrigeri over 2 years ago

anonym wrote:

sajolida wrote:

anonym: please confirm which exact HTML bit you depend upon and then I think you can close this ticket.

I'm not sure which one since I know very little about HTML/CSS. What I care about is the title that decides the Tor Browser window title. In other words, I want the start page (t.b.o/home) to always make Tor Browser's window title into e.g. "Tails - News - Tor Browser" or "Tails - Home - Tor Browser" or any other never-changing string you are happy with.

Is this OK? If not, perhaps a fixed prefix would be something anonym can work with.

#18 Updated by sajolida over 2 years ago

  • Target version changed from Tails_2.12 to Tails_3.0

#19 Updated by sajolida over 2 years ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (sajolida)

I don't know of any mechanism in ikiwiki that allows to display something different in <title> and <span class="title"> so we'll have to do ugly workarounds.

Also available in: Atom PDF