Project

General

Profile

Feature #12106

Feature #8415: Migrate from aufs to overlayfs

Adjust test suite to overlayfs

Added by intrigeri over 3 years ago. Updated about 1 month ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
Test suite
Target version:
Start date:
01/02/2017
Due date:
% Done:

100%

Estimated time:
4.00 h
Feature Branch:
feature/8415-overlayfs+force-all-tests
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

At least is_persistent? is aufs-specific.


Related issues

Blocked by Tails - Feature #9373: Make tails-iuk support overlayfs Resolved
Blocks Tails - Feature #16209: Core work: Foundations Team Confirmed

Associated revisions

Revision 425206fa (diff)
Added by intrigeri 4 months ago

Test suite: use an overlayfs-based test IUK (refs: #9373, #12106)

I did not create nor upload that IUK yet, nor did I generate the corresponding
UDFs and their signatures.

Revision 7cb37108 (diff)
Added by intrigeri 4 months ago

Add UDFs for 1.0~testoverlayfs (refs: #9373, #12106)

Without signatures for now as I can't generate them at the moment.

Revision 716470c5 (diff)
Added by intrigeri 4 months ago

Add UDFs for 1.1~testoverlayfs (refs: #9373, #12106)

Without signatures for now as I can't generate them at the moment.

History

#1 Updated by Anonymous about 2 years ago

  • Assignee set to anonym

The parent ticket seems to be part of our roadmap, so assigning this ticket to the person responsible for the parent ticket. I'll let you verify if this is correct or if somebody else is responsible for this, or nobody.

#2 Updated by intrigeri over 1 year ago

  • Assignee changed from anonym to CyrilBrulebois
  • Target version set to Tails_3.11

As per summit meeting.

#3 Updated by intrigeri over 1 year ago

#4 Updated by intrigeri over 1 year ago

  • Estimated time set to 4.00 h

#5 Updated by intrigeri over 1 year ago

  • Blocked by Feature #9373: Make tails-iuk support overlayfs added

#6 Updated by intrigeri over 1 year ago

  • Target version changed from Tails_3.11 to Tails_3.13

#7 Updated by intrigeri about 1 year ago

  • Target version changed from Tails_3.13 to 2019

#8 Updated by intrigeri about 1 year ago

#9 Updated by intrigeri about 1 year ago

#10 Updated by intrigeri almost 1 year ago

  • Assignee deleted (CyrilBrulebois)

#11 Updated by intrigeri 4 months ago

  • Feature Branch changed from feature/8415-overlayfs-stretch to feature/8415-overlayfs+force-all-tests

#12 Updated by intrigeri 4 months ago

  • Status changed from Confirmed to In Progress

#13 Updated by intrigeri 4 months ago

  • Target version changed from 2019 to Tails_4.5

The milestone for this is "March 2020" so the current goal is to have this ready in time for 4.5~rc1. We might manage to complete this earlier though — we'll see!

#14 Updated by intrigeri 4 months ago

  • Priority changed from Normal to High

#15 Updated by intrigeri about 1 month ago

  • Assignee set to intrigeri

#16 Updated by intrigeri about 1 month ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (intrigeri)

Full test suite passed on my local Jenkins, except the 3 automatic upgrade scenarios (because this run predates the work I did on #17440), so I think we're done here.

#17 Updated by intrigeri about 1 month ago

  • % Done changed from 0 to 100

Also available in: Atom PDF