Project

General

Profile

Bug #12088

Test suite fails for feature/stretch on Jenkins due to lack of space in /tmp/TailsToaster

Added by intrigeri almost 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
Category:
Continuous Integration
Target version:
Start date:
12/26/2016
Due date:
% Done:

100%

Feature Branch:
Type of work:
Sysadmin
Blueprint:
Starter:
Affected tool:

Description

https://jenkins.tails.boum.org/view/RM/job/test_Tails_ISO_feature-stretch/74/consoleFull says:

18:29:48 Feature: Icedove email client
18:29:48   As a Tails user
18:29:48   I may want to use an email client
18:29:48
18:29:48   Background:                                                                      # features/icedove.feature:7
18:30:37     Given I have started Tails from DVD and logged in and the network is connected # features/step_definitions/snapshots.rb:197
18:30:37       Call to virDomainSaveFlags failed: operation failed: domain save job: unexpectedly failed (Libvirt::Error)
18:30:37       ./features/support/helpers/vm_helper.rb:589:in `save'
18:30:37       ./features/support/helpers/vm_helper.rb:589:in `save_snapshot'
18:30:37       ./features/step_definitions/snapshots.rb:190:in `reach_checkpoint'
18:30:37       ./features/step_definitions/snapshots.rb:198:in `/^I\ have\ started\ Tails\ from\ DVD\ and\ logged\ in\ and\ the\ network\ is\ connected$/'
18:30:37       features/icedove.feature:8:in `Given I have started Tails from DVD and logged in and the network is connected'

Around that time, thanks to home-made monitoring:

$ df $df_options
Filesystem     Type   Size  Used Avail Use% Mounted on
tmpfs          tmpfs   13G   13G 1017M  93% /tmp/TailsToaster

$ free $free_options
             total       used       free     shared    buffers     cached
Mem:         23107      20664       2443      12310         61      14093
-/+ buffers/cache:       6509      16597
Swap:            0          0          0

So, for some reason, running the test suite on current feature/stretch requires more disk space (and probably more RAM).
I'll investigate why (it might be caused by the changes I did for #12055).


Related issues

Related to Tails - Bug #12092: The Greeter keeps eating lots of memory after logging in Resolved 12/27/2016

History

#2 Updated by intrigeri almost 3 years ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10

The failure is caused by lacking disk space to save snapshots.

#3 Updated by intrigeri almost 3 years ago

Given the isotesters 1 more GB of RAM and tmpfs, we'll see.

#4 Updated by intrigeri almost 3 years ago

  • Related to Bug #12092: The Greeter keeps eating lots of memory after logging in added

#5 Updated by anonym almost 3 years ago

It seems the memory bump fixed the "domain save job" operation:

https://jenkins.tails.boum.org/job/test_Tails_ISO_feature-stretch/77/

There's still another Libvirt::Error issues remaining but that is for #12067 AFAICT so I think this ticket can be closed.

#6 Updated by intrigeri almost 3 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 10 to 100
  • Type of work changed from Research to Sysadmin

Also available in: Atom PDF