Project

General

Profile

Feature #12075

Feature #14877: Donation campaign 2018

Add Riseup Labs's postal addresses on the donation page for US checks

Added by sajolida about 3 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Fundraising
Target version:
Start date:
12/23/2016
Due date:
% Done:

0%

Feature Branch:
web/12075-us-check
Type of work:
Website
Blueprint:
Starter:
Yes
Affected tool:

Description

This could be useful for people sending checks.


Related issues

Duplicated by Tails - Bug #15351: Add Riseup Labs' postal address to our donation page Duplicate 02/27/2018

Associated revisions

Revision ae5e55fe (diff)
Added by sajolida over 1 year ago

Add Riseup Labs address for US checks (Will-fix: #12075)

Revision fdc0f050
Added by sajolida over 1 year ago

Merge branch 'web/12075-us-check' (Closes: #12075)

History

#1 Updated by sajolida about 3 years ago

  • Parent task set to #12035

#2 Updated by sajolida about 3 years ago

  • Assignee deleted (sajolida)

#3 Updated by Anonymous almost 3 years ago

  • Assignee set to Anonymous

While using checks is relevant in countries such as France or USA, it is mostly irrelevant, to my knowledge, in other countries.

However, I find this still useful, and I'd like to add the bank address too. This is often necessary for example for bank wires from the UK to Europe, the person making the donation needs to add the bank and receiver address.

#4 Updated by Anonymous over 2 years ago

  • Status changed from Confirmed to Rejected

u wrote:

While using checks is relevant in countries such as France or USA, it is mostly irrelevant, to my knowledge, in other countries.

However, I find this still useful, and I'd like to add the bank address too. This is often necessary for example for bank wires from the UK to Europe, the person making the donation needs to add the bank and receiver address.

I've added the bank address in #14832.

Now.. I dont't think anymore that we need to add CCT's address. Most people who would need that, can donate through other means. Basically, for a SEPA wire it's not needed. Checks are not fancy in Germany since ages. It's sometimes needed for people from the UK wanting to send money - they'd be the only beneficiaries of such a change. So I will close this ticket as irrelevant in the end.

#5 Updated by Anonymous over 2 years ago

  • Status changed from Rejected to Confirmed

#6 Updated by Anonymous about 2 years ago

  • Parent task deleted (#12035)

Moving this out of the donation campaign.

#7 Updated by Anonymous about 2 years ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10

I've sent an email to Riseup to ask them what they think about this.

#8 Updated by Anonymous about 2 years ago

We can add their address but we need to specify that only US checks are accepted.

#9 Updated by Anonymous almost 2 years ago

Riseup Labs
PO Box 4282
Seattle, WA 98194

#10 Updated by sajolida almost 2 years ago

  • Subject changed from Add postal addresses of our fiscal sponsors on the donation page to Add Riseup Labs's postal addresses on the donation page

This is about Riseup Labs only then.

#11 Updated by sajolida almost 2 years ago

  • Duplicated by Bug #15351: Add Riseup Labs' postal address to our donation page added

#12 Updated by sajolida over 1 year ago

  • Subject changed from Add Riseup Labs's postal addresses on the donation page to Add Riseup Labs's postal addresses on the donation page for US checks
  • Category set to Fundraising
  • Status changed from In Progress to Confirmed
  • Assignee changed from Anonymous to sajolida
  • Target version set to Tails_3.10.1
  • % Done changed from 10 to 0
  • Parent task set to #14877

#13 Updated by sajolida over 1 year ago

  • Assignee changed from sajolida to moire
  • QA Check set to Ready for QA
  • Feature Branch set to web/12075-us-check

Here's a branch.

moire: Tell me if you need help regarding how to review that.

#14 Updated by sajolida over 1 year ago

  • Status changed from Confirmed to In Progress

#15 Updated by moire over 1 year ago

  • QA Check changed from Ready for QA to Pass

Content: ok
Layout: ok

#16 Updated by sajolida over 1 year ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (moire)

#17 Updated by intrigeri over 1 year ago

  • Target version changed from Tails_3.10.1 to Tails_3.9.1

Also available in: Atom PDF