Project

General

Profile

Feature #12055

Feature #5464: Revamp Greeter interface

Feature #8230: Greeter revamp: Phase 1

Update test suite for Greeter revamp, phase 1

Added by intrigeri over 2 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
Test suite
Target version:
Start date:
12/21/2016
Due date:
% Done:

100%

QA Check:
Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Greeter

Related issues

Related to Tails - Bug #12093: Missing "Read only" option for persistence in new Greeter Rejected 12/28/2016

Associated revisions

Revision e1c091ef (diff)
Added by intrigeri over 2 years ago

Test suite: start updating images for the revamped Greeter (refs: #12055).

Revision dbd8691b (diff)
Added by intrigeri over 2 years ago

Test suite: update more images for the revamped Greeter (refs: #12055).

Revision a12be5e2 (diff)
Added by intrigeri over 2 years ago

Test suite: start adjusting for the way additional settings are handled in the new Greeter (refs: #12055).

Revision c1f5a7af (diff)
Added by intrigeri over 2 years ago

Test suite: update MAC spoofing settings handling for the new Greeter (refs: #12055).

Revision 9292fde0 (diff)
Added by intrigeri over 2 years ago

Test suite: update Tor bridges handling for the new Greeter (refs: #12055).

Revision e737c001 (diff)
Added by intrigeri over 2 years ago

Test suite: update offline mode handling for the new Greeter (refs: #12055).

Revision e336363a (diff)
Added by intrigeri over 2 years ago

Test suite: update language handling for new Greeter (refs: #12055).

Revision e26b62db (diff)
Added by intrigeri over 2 years ago

Test suite: update persistence handling for the new Greeter (refs: #12055).

Revision 90b8b989 (diff)
Added by anonym over 2 years ago

Test suite: drop usage and tests of read-only persistence.

We won't have it in Tails 3.0~beta1 since the Greeter doesn't have
that option, and it's not even sure we'll reintroduce it since it's
apparently quite buggy and not widely used.

Will-fix: #12055
Refs: #12093

History

#1 Updated by intrigeri over 2 years ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 20

Done most of it, let's see what Jenkins thinks.

#2 Updated by intrigeri over 2 years ago

FTR, the main part left to update is persistence handling, but I think it's probably blocked by the breakage caused on #11873.

#3 Updated by intrigeri over 2 years ago

  • Target version set to Tails_3.0

I'm going to merge the new Greeter into feature/stretch, so this will become a blocker for Tails 3.0.

#4 Updated by intrigeri over 2 years ago

  • Blocked by Bug #12093: Missing "Read only" option for persistence in new Greeter added

#5 Updated by intrigeri over 2 years ago

  • % Done changed from 20 to 50

I think I'm mostly done here, except the part that's blocked by #12093.

#6 Updated by intrigeri over 2 years ago

  • Priority changed from Normal to Elevated

We need to do something (possibly temporary) for 3.0~beta1 as there's no realistic way to re-add the "read only" persistence option in time for it: https://mailman.boum.org/pipermail/tails-ux/2017-January/003331.html.

The best option I can think of right now is to add a (not documented, not supported) kernel command-line option to enable read only persistence. It should minimize the amount of changes we have to do in the test suite (where we use read only persistence, presumably for optimization purposes, quite a lot), and allow to easily revert them if UX folks decide to re-add this option to the Greeter.

#7 Updated by intrigeri over 2 years ago

  • Blocked by deleted (Bug #12093: Missing "Read only" option for persistence in new Greeter)

#8 Updated by intrigeri over 2 years ago

  • Related to Bug #12093: Missing "Read only" option for persistence in new Greeter added

#9 Updated by intrigeri over 2 years ago

  • Assignee changed from intrigeri to anonym
  • QA Check set to Info Needed

#10 Updated by anonym over 2 years ago

intrigeri wrote:

[in the test suite] we use read only persistence, presumably for optimization purposes, quite a lot

There are a few places where we still use it to optimize for touching the persistence partition less, which made sense back when we didn't use snapshots so changes would persist between scenarios, which could cause problems. These instances can easily and safely be switched to read/write persistence now.

#11 Updated by anonym over 2 years ago

I forgot to say: because of what I just said, we might as well just completely drop read-only persistence for 3.0~beta1, and skip the kernel cmdline option.

#12 Updated by intrigeri over 2 years ago

  • Assignee changed from anonym to intrigeri
  • QA Check deleted (Info Needed)

OK, will try that.

#13 Updated by intrigeri over 2 years ago

  • Assignee changed from intrigeri to anonym

anonym proposed to handle this :)

#14 Updated by anonym over 2 years ago

  • Assignee changed from anonym to intrigeri

I ripped out read-only persistence from the test suite in 90b8b989ac2374636ff3cec10006eca65e262f29.

#15 Updated by intrigeri over 2 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 50 to 100

I think we're done here. Let's re-open if we discover more stuff to update.

#16 Updated by intrigeri about 2 years ago

  • Assignee deleted (intrigeri)

Also available in: Atom PDF