Project

General

Profile

Bug #11987

Feature #5630: Reproducible builds

ikiwiki includes "Posted" timestamps in some generated web pages

Added by intrigeri about 3 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Build system
Target version:
-
Start date:
11/22/2016
Due date:
% Done:

100%

Feature Branch:
451f:tails/feature/11987+remove_ikiwiki_timestamps
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

We've seen that break reproducibility once. Looks like they come from templates/archivepage.tmpl and/or templates/inlinepage.tmpl.

It might have been fixed by 541bbe5fd3c1127232ce271041f9dddb94e3f5d7 when one uses cleanall, but this remains to be verified.


Related issues

Related to Tails - Feature #11966: Reproducible website build Resolved 11/19/2016

Associated revisions

Revision 105836f4
Added by intrigeri over 2 years ago

Merge remote-tracking branch '451f/feature/11987+remove_ikiwiki_timestamps' (Closes: #11987)

History

#1 Updated by intrigeri about 3 years ago

#2 Updated by u over 2 years ago

  • Assignee changed from intrigeri to u

#3 Updated by u over 2 years ago

After verification using a recent build, these timestamps are still present.
We will need to modify the page templates in our wiki and/or report this upstream (however i doubt that this will be accepted as an upstream modification).

#4 Updated by u over 2 years ago

  • Feature Branch set to 451f:tails/feature/11987+remove_ikiwiki_timestamps

#5 Updated by u over 2 years ago

I've built the wiki locally and this seems to work now. The only left "timestamp" is the one concerning the latest release in the sidebar.

#6 Updated by u over 2 years ago

  • Assignee changed from u to intrigeri
  • % Done changed from 0 to 40
  • QA Check set to Ready for QA

#7 Updated by intrigeri over 2 years ago

  • Status changed from Confirmed to In Progress

#8 Updated by intrigeri over 2 years ago

  • % Done changed from 40 to 50

Looks good! Code review passes. I would have preferred 2 commits (one that imports the upstream files, and one that modifies them) so it's easier to maintain our delta in the future, but our custom changes seem simple enough so I won't block on it. Will test locally and merge if it works for me! :)

#9 Updated by u over 2 years ago

  • % Done changed from 50 to 40

intrigeri wrote:

Looks good! Code review passes. I would have preferred 2 commits (one that imports the upstream files, and one that modifies them) so it's easier to maintain our delta in the future, but our custom changes seem simple enough so I won't block on it. Will test locally and merge if it works for me! :)

ack. One can also just do a diff with the files in /usr/share/ikiwiki/templates.

#10 Updated by intrigeri over 2 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 40 to 100

#11 Updated by intrigeri over 2 years ago

  • Assignee deleted (intrigeri)
  • QA Check changed from Ready for QA to Pass

Also available in: Atom PDF