Project

General

Profile

Bug #11975

Feature #10178: Rephrase syslinux screen

Wording of boot menu entries ("Live") is unclear

Added by intrigeri almost 3 years ago. Updated almost 3 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
11/20/2016
Due date:
% Done:

100%

Feature Branch:
feature/11975-boot-menu-wording
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

As suggested by Chris Lamb <> on tails-dev in September, 2015, "Live" is hard to undertand. Then an interesting discussion about it happened on tails-dev@ and tails-ux@, but in the end no consensus was achieved. It seems to me that most of the proposals on these threads are better than the current state of things, so IMO until -ux@ tells us what we should put in there, we can pick basically any of them, and improve things. This ticket is about doing that.

Associated revisions

Revision 71adacf9 (diff)
Added by intrigeri almost 3 years ago

Boot menu: drop the "Boot Tails" title and replace "Live" entries with "Boot Tails" ones (refs: #11975).

Revision 5b32e6d1 (diff)
Added by intrigeri almost 3 years ago

Change syslinux menu entries from "Boot Tails" to "Tails" (refs: #11975).

Revision ffd41445 (diff)
Added by intrigeri almost 3 years ago

Start adjusting end-user documentation to match new syslinux menu (refs: #11975).

Revision de23b8d8 (diff)
Added by intrigeri almost 3 years ago

List a bunch of parts of end-user doc that need adjustments to match updated syslinux menu (refs: #11975).

Revision 860a4835 (diff)
Added by intrigeri almost 3 years ago

Replace "Boot Tails" with "boot loader menu", and adjust styling to the fact this name is not displayed anymore (refs: #11975).

I've used the same styling that was already used in one place for "boot loader
menu" in startup_options.mdwn, for consistency.

Revision 0d57f78a (diff)
Added by intrigeri almost 3 years ago

Replace "boot menu" with "boot loader menu" when it's about the later (refs: #11975).

Note that this was less mechanical than expected: there are places where "boot
menu" means "whatever menu the BIOS/firmware offers to pick a boot device".
I did not change those, so now we have two different phrasings, for two
different menus, which sounds better than reusing the same wording in
both cases.

Revision 15afb62a (diff)
Added by intrigeri almost 3 years ago

Replace the "boot_menu" anchor with "boot_loader_menu", preserving backwards compatibility with links already published elsewhere (refs: #11975).

I figured it was better if URLs used the same wording as the text they're about,
especially when the previous wording ("boot menu") is used elsewhere in our doc
to mean something else.

Revision 155159fd (diff)
Added by intrigeri almost 3 years ago

Update screenshots and alt text according to syslinux menu update (refs: #11975).

Revision cb918406
Added by anonym almost 3 years ago

Merge remote-tracking branch 'origin/feature/11975-boot-menu-wording' into devel

Fix-committed: #11975

History

#1 Updated by intrigeri almost 3 years ago

  • Description updated (diff)

#2 Updated by intrigeri almost 3 years ago

  • Feature Branch set to feature/11975-boot-menu-wording

#3 Updated by intrigeri almost 3 years ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10

Left to do: update doc, screenshots, test suite.

#4 Updated by sajolida almost 3 years ago

  • Parent task set to #10178

I was already tracking this in #10178 but since you already wrote a patch I don't dare closing this one as a duplicate. At least I'm making it a subtask.

#5 Updated by sajolida almost 3 years ago

You can find the latest proposal in the description of #10178.

#6 Updated by intrigeri almost 3 years ago

At least I'm making it a subtask.

Thanks! This sounds the right semantics to me: this ticket is about getting a 1st iteration benefit users quickly. Further improvements can be discussed on the parent ticket.

#7 Updated by intrigeri almost 3 years ago

  • Status changed from In Progress to Rejected
  • Assignee deleted (intrigeri)
  • % Done changed from 10 to 100

So this triggered doing the full thing (#10178), which is good news and voids the purpose of this ticket. What this ticket was originally about is fully done on the topic branch, and what's left to do is about the bonus work added as part of #10178.

Also available in: Atom PDF