Project

General

Profile

Bug #11945

Prevent tails-installer in Debian from migrating to stable

Added by u almost 3 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Installation
Target version:
Start date:
02/02/2017
Due date:
% Done:

100%

Feature Branch:
Type of work:
Debian
Blueprint:
Starter:
Affected tool:
Installer

Description

The Tails ISO format might change, and we are not sure that our current installer will still be able to install Tails images in ~2 years. That's why we don't want it to be in Debian stable (unless we want to to talk to the Debian Release team about how this could be updated in stable and analyze what would have happened if we had put tails-installer in Jessie - but we doubt that we want to adopt this solution.)

So, an RC will need to be filed against the package but only once the Stretch freeze has started. This is because an RC bug prevents packages to migrate from unstable to testing and a package which is not in testing cannot have a backport. This is the release schedule for Debian Stretch:

  • 2016-11-05: Transition freeze (general freeze of transitions)
  • 2017-01-05: "Soft" freeze (no new packages, no re-entry, normal migrations)
  • 2017-02-05: Full freeze

So this should happen right after the full freeze.

Putting target version 2.9, but this is just so that I'll remember around when I need to do this.

History

#1 Updated by u almost 3 years ago

Here is a text for the email which needs to be sent earliest on february 5th 2017.

To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: tails-installer: Should not be part of Stretch

Package: tails-installer
Severity: serious

I'm opening this RC bug in order to prevent tails-installer from migrating to testing.

The Tails ISO format might change, and upstream is not sure whether the current installer will still be able to install Tails images in ~2 years. That's why upstream doesn't want it to be in Debian stable.
This bug is opened in coordination with upstream.

It'll be easier and safer to provide new versions to users using stable-backports.

#2 Updated by intrigeri almost 3 years ago

  • Category set to Installation

#3 Updated by anonym almost 3 years ago

  • Target version changed from 284 to Tails 2.10

#4 Updated by anonym over 2 years ago

  • Target version changed from Tails 2.10 to Tails_2.11

#5 Updated by u over 2 years ago

  • Status changed from Confirmed to Resolved
  • Assignee deleted (u)
  • % Done changed from 0 to 100

Also available in: Atom PDF