Project

General

Profile

Bug #11921

No more "Root Terminal" launcher in Stretch

Added by sajolida almost 3 years ago. Updated almost 3 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
11/15/2016
Due date:
% Done:

100%

Feature Branch:
Type of work:
Test
Blueprint:
Starter:
Affected tool:

Description

It used to be in Applications → System Tools → Root Terminal and we are relying on it in the documentation.

The gksu package in installed both in 2.6 and Stretch while in 2.6 I have a /usr/share/applications/gksu.desktop but not in Stretch.


Related issues

Related to Tails - Bug #12000: Adjust doc for Stretch: starting graphical applications as root Rejected 11/27/2016

History

#1 Updated by intrigeri almost 3 years ago

The gksu package in installed both in 2.6 and Stretch while in 2.6 I have a /usr/share/applications/gksu.desktop but not in Stretch.

/usr/share/applications/gksu.desktop is shipped in the ISO, but we delete it in the Greeter unless an administration password is set. This should work just the same as in 2.6, but of course we can't confirm this right now due to #11919. I'll test again once #11919 is fixed.

#2 Updated by intrigeri almost 3 years ago

  • Status changed from Confirmed to Rejected
  • % Done changed from 0 to 100

Confirmed (with a feature/stretch that has the fix for #11919) that it works just like on Tails 2.x => rejecting. Please reopen if there's a problem I missed.

#3 Updated by sajolida almost 3 years ago

  • Status changed from Rejected to In Progress
  • Assignee changed from intrigeri to sajolida
  • Type of work changed from Research to Test

I'll double-check.

#4 Updated by intrigeri almost 3 years ago

  • Related to Bug #12000: Adjust doc for Stretch: starting graphical applications as root added

#5 Updated by intrigeri almost 3 years ago

  • QA Check set to Ready for QA

#6 Updated by anonym almost 3 years ago

  • Status changed from In Progress to Rejected
  • Assignee deleted (sajolida)
  • QA Check deleted (Ready for QA)

I can confirm that the launcher exists in the same place as in Tails/Jessie (Applications -> System Tools -> Root Terminal).

Also available in: Atom PDF