Project

General

Profile

Feature #11899

Upgrade OpenPGP applet to 1.0

Added by intrigeri over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
11/05/2016
Due date:
% Done:

100%

QA Check:
Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:
OpenPGP Applet

Description

openpgp-applet 1.0 was uploaded to sid (#7711). We should backport it for Jessie, test it in there, and upgrade to 1.0-1~bpo8+1 e.g. in Tails 2.8.


Related issues

Blocked by Tails - Feature #7711: Port the OpenPGP applet to GTK+ 3 Resolved 08/01/2014

Associated revisions

Revision 2c471a27 (diff)
Added by intrigeri over 2 years ago

Install OpenPGP Applet from jessie-backports, instead of from Stretch.

Currently our devel branch FTBFS since Stretch got openpgp-applet 1.0,
that has a new dependency. For now let's revert to 0.9.1, that is the
version we installed before openpgp-applet 1.0 migrated to testing,
modulo "~bpo8+1". Ticket #11899 is there to track the upgrade to 1.0.

refs: #11899

Revision dfc5738b (diff)
Added by intrigeri over 2 years ago

Install OpenPGP Applet from jessie-backports, instead of from Stretch.

Currently our devel branch FTBFS since Stretch got openpgp-applet 1.0,
that has a new dependency. For now let's revert to 0.9.1, that is the
version we installed before openpgp-applet 1.0 migrated to testing,
modulo "~bpo8+1". Ticket #11899 is there to track the upgrade to 1.0.

refs: #11899

History

#1 Updated by intrigeri over 2 years ago

  • Blocked by Feature #7711: Port the OpenPGP applet to GTK+ 3 added

#2 Updated by intrigeri over 2 years ago

nodens: please reassign to me once you have the backport ready and tested on Jessie. Then I'll upload and will deal with the Tails side of things :)

#3 Updated by nodens over 2 years ago

  • Status changed from Confirmed to In Progress

This means also backporting libgtk3-simplelist-perl (done, in NEW).
Testing in progress !

#4 Updated by nodens over 2 years ago

  • Assignee changed from nodens to intrigeri

So far so good, no obvious problem with gpg2 (that was my main concern), or any test that I have done (clearsign, (en|de)crypt, sign with public key, or symmetric (en|de)crypt with passphrase.

So, pushed in Debian, needs to be uploaded to backports (but libgtk3-simplelist-perl has to leave NEW first).

Cheers !

#5 Updated by intrigeri over 2 years ago

  • Target version changed from Tails_2.9.1 to Tails 2.10

#6 Updated by nodens over 2 years ago

FYI, libgtk3-simplelist-perl has been accepted into backports, so it's just a matter of uploading the updated openpgp-applet backport.

Cheers !

#7 Updated by intrigeri over 2 years ago

  • Type of work changed from Debian to Code

#8 Updated by intrigeri over 2 years ago

  • % Done changed from 0 to 10

Recent builds from the devel branch include it, but the corresponding automated tests are flagged as fragile, so we have no feedback from Jenkins about whether it breaks anything.

#9 Updated by intrigeri over 2 years ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (intrigeri)
  • % Done changed from 10 to 100

Test suite passes locally so we're done here.

#10 Updated by anonym over 2 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF