Project

General

Profile

Bug #11872

Florence systray icon sometimes does not show up

Added by bertagaz about 3 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Test suite
Target version:
Start date:
10/10/2016
Due date:
% Done:

0%

Feature Branch:
Type of work:
Research
Blueprint:
Starter:
Affected tool:
On-screen keyboard

Description

Seen it several times in Jenkins: sometimes tests fails at the "desktop is ready" step because the Florence systray does not even shows up.

First time this error happens in Jenkins is in 2016 August 25, so it's unlikely that it is related to the introduction of #8312, which was merged a few days after that (on the 29th).

It seems to happen quite often in Jenkins.

See https://jenkins.tails.boum.org/job/test_Tails_ISO_devel/499/

Might be that the icon is invisible, but the Florence keyboard is still accessible by clicking on its systray zone, as mentioned in #11479.


Related issues

Related to Tails - Bug #8312: Better integrate Florence within GNOME Shell, or replace it Resolved 11/20/2014
Related to Tails - Bug #11479: "the Tails desktop is ready" step is fragile due to buggy display of Florence systray icon Resolved 05/24/2016

History

#1 Updated by bertagaz about 3 years ago

  • Related to Bug #8312: Better integrate Florence within GNOME Shell, or replace it added

#2 Updated by bertagaz about 3 years ago

  • Related to Bug #11479: "the Tails desktop is ready" step is fragile due to buggy display of Florence systray icon added

#3 Updated by intrigeri about 3 years ago

  • Category set to Test suite

#4 Updated by u over 2 years ago

  • Related to Bug #12385: The virtual keyboard in the Greeter allows to type only a limited set of keys added

#5 Updated by u over 2 years ago

I have run into this issue when I run 3.0 in a virt-manager VM. I can't click on any invisible icon though, there is nothing happening. No, apparently this is totally unrelated. Forget about it.

#6 Updated by u over 2 years ago

  • Related to deleted (Bug #12385: The virtual keyboard in the Greeter allows to type only a limited set of keys)

#7 Updated by intrigeri over 2 years ago

I have this when I run 3.0 in a virt-manager VM.

OK, please send a WhisperBack report then :)

#8 Updated by intrigeri about 2 years ago

  • Affected tool set to On-screen keyboard

#9 Updated by intrigeri about 2 years ago

  • Status changed from Confirmed to Fix committed
  • Target version set to Tails_3.2

We don't ship Florence anymore (#8281) and the GNOME on-screen keyboard has no such bug.

#10 Updated by anonym about 2 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF