Project

General

Profile

Bug #11853

ISO build from devel fails with mesa 12.0.3-1~bpo8+1

Added by intrigeri almost 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
-
Target version:
Start date:
09/30/2016
Due date:
% Done:

100%

Feature Branch:
bugfix/11853-mesa-12.0.3
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

Build fails with "xorg : Depends: libgl1-mesa-dri but it is not going to be installed", presumably since mesa 12.0.3-1~bpo8+1 was uploaded to jessie-backports.


Related issues

Related to Tails - Bug #11850: Only software rendering (no hardware acceleration) on some AMD GPUs since 2.4 Resolved 09/28/2016
Related to Tails - Bug #11831: NVIDIA Maxwell series graphic card: X.Org doesn't start, or slow graphics operations Resolved 04/10/2017

Associated revisions

Revision c0e89224 (diff)
Added by intrigeri almost 3 years ago

Update APT pinning to cover all binary packages built from src:mesa.

So far, even though we now install most of mesa from jessie-backports, due to
insufficient pinning we were still installing an older version of some bits of
it from our custom APT repository.

refs: #11853

Revision e4c2562b (diff)
Added by intrigeri almost 3 years ago

Install packages built from src:llvm-toolchain-3.8 from jessie-backports.

This is required to install mesa 12.0.3, that is now in jessie-backports.

refs: #11853

Revision bc6a783c
Added by anonym almost 3 years ago

Merge remote-tracking branch 'origin/bugfix/11853-mesa-12.0.3' into devel

Fix-committed: #11853, #11850

Revision a6a06c0a
Added by anonym over 2 years ago

Merge remote-tracking branch 'origin/bugfix/11853-mesa-12.0.3' into stable

Fix-committed: #11853, #11850

History

#1 Updated by intrigeri almost 3 years ago

  • Related to Bug #11850: Only software rendering (no hardware acceleration) on some AMD GPUs since 2.4 added

#2 Updated by intrigeri almost 3 years ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10
  • Feature Branch set to bugfix/11853-mesa-12.0.3

#3 Updated by intrigeri almost 3 years ago

  • Assignee changed from intrigeri to anonym
  • % Done changed from 10 to 50
  • QA Check set to Ready for QA

Please review'n'merge. Note that I've sneaked in a somewhat unrelated change, i.e. a potential fix for #11850, that I'm going to send a call for testing about on tails-testers@ once Jenkins has built an ISO.

#4 Updated by intrigeri almost 3 years ago

  • Related to Bug #11831: NVIDIA Maxwell series graphic card: X.Org doesn't start, or slow graphics operations added

#5 Updated by intrigeri almost 3 years ago

intrigeri wrote:

Note that I've sneaked in a somewhat unrelated change, i.e. a potential fix for #11850,

The OP confirmed on #11850 that it adds support for their hardware.

#6 Updated by anonym almost 3 years ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (anonym)
  • % Done changed from 50 to 100
  • QA Check changed from Ready for QA to Pass

Merged!

#7 Updated by intrigeri almost 3 years ago

Successfully tested on MacBook Pro 8,1 13-inch (Intel 2nd-gen Core integrated graphics). Can't test on a ThinkPad nor AMD GPU since I don't have any handy at the moment.

#8 Updated by anonym almost 3 years ago

  • Target version changed from Tails_2.9.1 to Tails_2.7.1

#9 Updated by anonym almost 3 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF