Project

General

Profile

Bug #11816

Bug #10288: Fix newly identified issues to make our test suite more robust and faster

Test suite often freezes after clicking "Login" in the Greeter

Added by intrigeri about 3 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
Test suite
Target version:
Start date:
09/20/2016
Due date:
% Done:

100%

Feature Branch:
Type of work:
Research
Blueprint:
Starter:
Affected tool:

Description

We've seen this a lot especially since we re-enabled the USB tests. Adding a 2nd vcpu to TailsToaster has helped a bit, but not enough.


Related issues

Related to Tails - Bug #11617: Clicking "Yes" for "More options?" in the Greeter sometimes fails in Jenkins Resolved 08/01/2016
Related to Tails - Bug #13470: Step "Tails Greeter has applied all settings" is fragile Resolved 07/14/2017
Blocked by Tails - Feature #12284: Deal with January 2017 false positive scenarios Rejected 03/04/2017 03/10/2017
Blocked by Tails - Feature #12286: Deal with February 2017 false positive scenarios Rejected 03/04/2017 03/10/2017

History

#1 Updated by intrigeri about 3 years ago

  • Status changed from Confirmed to In Progress
  • Assignee set to intrigeri
  • Target version set to Tails_2.7

We currently allocate 52 vcpus + soon 1 for im and 1 for weblate = 54 vcpus on lizard, while we "only" have 48 cores (hyperthreads). There's a theory that says that overcommitting vcpus is badly supported. So I've just shut down 2 isotesters (= 2 * 3 = 6 vcpus) so that we stop overcommitting vcpus. I'll have another look in a couple weeks and see if this fixes this problem (likely not, but worth trying :) Setting assignee and target version so that I don't forget about it, but if that fails don't expect me to fix the other root cause of this problem.

#2 Updated by intrigeri about 3 years ago

I've seen this bug happen today (https://jenkins.tails.boum.org/job/test_Tails_ISO_feature-11832-tor-0.2.8.8/4/) at a time when it was the only test job running, so I think we can discard the overloaded platform hypothesis, and I'll re-enable the two isotesters.

#3 Updated by intrigeri about 3 years ago

  • Status changed from In Progress to Confirmed
  • Assignee deleted (intrigeri)
  • Target version deleted (Tails_2.7)

#4 Updated by intrigeri almost 3 years ago

  • Related to Bug #11617: Clicking "Yes" for "More options?" in the Greeter sometimes fails in Jenkins added

#5 Updated by anonym almost 3 years ago

I've seen the I enable more Tails Greeter options step fail in a similar way -- both the Yes and No buttons are pressed down, but the Login button is not turned into the Forward button. I strongly expect this issue to be related, so let's track that here as well for now.

(https://jenkins.tails.boum.org/job/test_Tails_ISO_stable/589/)

#6 Updated by anonym almost 3 years ago

I've also seen just the Yes and Forward buttons being stuck + freeze.

(https://jenkins.tails.boum.org/job/test_Tails_ISO_stable/579/)

#7 Updated by anonym over 2 years ago

  • Assignee set to anonym
  • Target version set to Tails_2.12
Ideas:
  • save journal as artifact when this failure occurs.
  • restart gdm/tails-greeter when this happens.

#8 Updated by intrigeri over 2 years ago

Have we ever seen this on Stretch with the new Greeter?

#9 Updated by intrigeri over 2 years ago

  • Blocked by Feature #12284: Deal with January 2017 false positive scenarios added

#10 Updated by intrigeri over 2 years ago

  • Blocked by Feature #12285: Deal with March 2017 false positive scenarios added

#11 Updated by intrigeri over 2 years ago

  • Blocked by Feature #12286: Deal with February 2017 false positive scenarios added

#12 Updated by anonym over 2 years ago

  • Target version changed from Tails_2.12 to Tails_3.0

#13 Updated by intrigeri over 2 years ago

  • Blocked by deleted (Feature #12285: Deal with March 2017 false positive scenarios)

#14 Updated by intrigeri over 2 years ago

  • Status changed from Confirmed to Resolved
  • Assignee deleted (anonym)
  • Target version changed from Tails_3.0 to Tails_3.0~rc1
  • % Done changed from 0 to 100

Never seen that with the new Greeter.

#15 Updated by intrigeri over 2 years ago

  • Related to Bug #13470: Step "Tails Greeter has applied all settings" is fragile added

Also available in: Atom PDF