Project

General

Profile

Bug #11790

Ship adwaita-qt

Added by intrigeri about 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Low
Assignee:
Category:
-
Target version:
Start date:
09/11/2016
Due date:
% Done:

100%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

This would make the few Qt apps we ship blend better into the GNOME desktop:

Associated revisions

Revision bda98270 (diff)
Added by intrigeri almost 3 years ago

Include adwaita-qt and enable it by default, so that Qt5 applications integrate nicely into a GNOME environment (refs: #11790).

Revision 9e08321f (diff)
Added by intrigeri almost 3 years ago

Also install adwaita-qt4 to style the Qt4 apps we ship consistently (refs: #11790).

Revision 9cb49556 (diff)
Added by intrigeri almost 3 years ago

Enable the Adwaita style for Qt4 (refs: #11790).

History

#1 Updated by intrigeri about 3 years ago

hi muri & spriver! If you're interested in helping with this ticket, next steps are:

  1. wait for adwaita-qt to be in sid
  2. boot an ISO built from feature/stretch
  3. install adwaita-qt
  4. try running our Qt apps with the adwaita style enabled; do we really need to pass a -style argument manually?
  5. report back if/how it works & looks, and if it feels worth it

#2 Updated by spriver about 3 years ago

  • Status changed from Confirmed to In Progress
  • Assignee set to spriver

adwaita-qt is now installable in Tails, I'll do some testing in the next days

#3 Updated by intrigeri about 3 years ago

adwaita-qt is now installable in Tails, I'll do some testing in the next days

Cool! I've started testing it on my sid system (with Marble).

#4 Updated by intrigeri about 3 years ago

marble -style adwaita indeed makes Marble look like a native GTK+ 3 app.

In theory one can "set the theme as your default via [their] DE's tools (like systemsettings or qt-config)".

#5 Updated by intrigeri about 3 years ago

  • % Done changed from 0 to 10
  • Type of work changed from Test to Discuss

Setting QT_STYLE_OVERRIDE=adwaita in the environment should be enough to make Adwaita the default theme for Qt5 apps. Download size for adwaita-qt + adwaita-qt-data is less than 300kB, which is basically negligible, so this sounds like a quick and easy win.

On the other hand we currently include only one Qt5 app (namely: Audacity). But we'll soon have another one (OnionShare), and a few more ones might be commonly installed as additional software by users (e.g. VLC and Marble).

So IMO the UX improvement it's worth the tiny size cost.

spriver, what do you think?

#6 Updated by spriver almost 3 years ago

I tested it today, mostly with onionshare-gui and vlc. I liked it a lot there. I could not notice a huge difference in the GUI in Audacity, but nevertheless we can include it, since the installation only costs 600kB on disk.
So let's go for it?

#7 Updated by intrigeri almost 3 years ago

  • Assignee changed from spriver to intrigeri
  • Type of work changed from Discuss to Code

So let's go for it?

Yeah! Thanks for trying it :)

#8 Updated by intrigeri almost 3 years ago

  • Subject changed from Consider shipping adwaita-qt to Ship adwaita-qt

#9 Updated by intrigeri almost 3 years ago

  • Assignee changed from intrigeri to spriver
  • % Done changed from 10 to 20
  • QA Check set to Ready for QA

Done on feature/stretch. spriver, can you try this on a future build of that branch, or should I?

#10 Updated by spriver almost 3 years ago

I can try this in the next days (:

#11 Updated by spriver almost 3 years ago

  • Assignee changed from spriver to intrigeri
  • QA Check changed from Ready for QA to Info Needed
Tested it now with mostly OnionShare and VLC. The GUI looks good at most points now (and blends in nicely into the overall GNOME style). But:
in VLC:
  • some menus (e.g. in the section "Video") which are greyed out without adwaita-qt, are not greyed out with. (they appear as if they'd work, but while hovering over them nothing happens)
  • drop-down menus do not pre-select entries while the mouse is being moved over them (e.g. "Effects and Filters → Equalizer → Presets" won't pre-select entries and has to be scrolled and menu entries have to be selected then manually from the list by clicking on them)

(I can provide screenshots if this is a bit unclear)

So, what should we do about this? Report it upstream? Keep adwaita-qt, despite it has some (minor) GUI issues in e.g. VLC then, but will give the application a look which blends better into the overall appearance of the desktop? (I could not find any other problems in e.g. Audacity or OnionShare) Drop adwaita-qt?

#12 Updated by intrigeri almost 3 years ago

  • QA Check changed from Info Needed to Dev Needed

Thanks for testing!

Regarding VLC: we don't include nor support it, the problem you're describing doesn't sound like a serious blocker to me, and you've seen no such problem in supported apps, so I'm not going to do anything about it personally.

In passing: there's now adwaita-qt4 (in addition to adwaita-qt), that does the same for Qt4. So I'll try including that one as well, to style the Qt4 (argh!) apps we still ship consistently.

#13 Updated by intrigeri almost 3 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 20 to 100
  • QA Check deleted (Dev Needed)

Seems to work fine for Qt4 apps as well.

Also available in: Atom PDF