Project

General

Profile

Bug #11781

Opening OpenPGP Applet multiple times creates as many icons in the task bar

Added by mercedes508 over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
-
Target version:
Start date:
09/04/2016
Due date:
% Done:

100%

Feature Branch:
bugfix/11781-hide-openpgp-applet-launcher
Type of work:
Code
Blueprint:
Starter:
Affected tool:
OpenPGP Applet

Description

Until Tails 2.5, there was no OpenPGP applet launcher in the Applications menu. In Tails 2.6~rc1, there is one, and then, when opening OpenPGP Applet through Applications → Accessories → OpenPGP Applet it creates an icon in the task bar (top right). Where an OpenPGP Applet already exists by the way. And clicking x times creates x identical icons.


Related issues

Related to Tails - Feature #7435: Add Tails OpenPGP Applet to the Applications menu Confirmed 06/22/2014

Associated revisions

Revision faab3ca9 (diff)
Added by intrigeri over 3 years ago

Hide OpenPGP Applet launcher from the Applications menu.

Until we have something (else than the systray icon) to launch, i.e. other bits
of #7433 are done, it makes no sense to have a launcher there in the context of
Tails, since we launch the applet by default, and added a confirmation dialog
for exiting it. And keeping the launcher around means that users will try
to run it more than once, which is not very well supported.

Note that we have to move the desktop file to /etc/xdg/autostart/:
both Hidden=true and OnlyShowIn= would not only hide the launcher,
but they would also inhibit the automatic startup of the applet.

refs: #11781

Revision dfad7a9b
Added by anonym over 3 years ago

Merge remote-tracking branch 'origin/bugfix/11781-hide-openpgp-applet-launcher' into testing

Fix-committed: #11781

History

#1 Updated by intrigeri over 3 years ago

  • Related to Feature #7435: Add Tails OpenPGP Applet to the Applications menu added

#2 Updated by intrigeri over 3 years ago

  • Description updated (diff)

#3 Updated by intrigeri over 3 years ago

  • Status changed from Confirmed to In Progress
  • Assignee set to intrigeri
  • % Done changed from 0 to 10
  • Feature Branch set to bugfix/11781-hide-openpgp-applet-launcher

#4 Updated by intrigeri over 3 years ago

  • Assignee changed from intrigeri to anonym
  • Priority changed from Normal to Elevated
  • % Done changed from 10 to 50
  • QA Check set to Ready for QA

This is a usability regression => bumping priority. Fix ready and tested, sorry for being so late!

#5 Updated by anonym over 3 years ago

  • Status changed from In Progress to 11
  • Assignee deleted (anonym)
  • % Done changed from 50 to 100
  • QA Check changed from Ready for QA to Pass

#6 Updated by anonym over 3 years ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF