Project

General

Profile

Bug #11780

Bug #10950: Bring gnome-sound-recorder back

GNOME Sound Recorder unusable because of "invalid capture settings"

Added by sajolida over 2 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Hardware support
Target version:
Start date:
09/04/2016
Due date:
% Done:

0%

QA Check:
Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

When I start GNOME Sound Recorder in 2.6~rc1 and press "Record" I get an error: Your audio capture settings are invalid.. If I try to record from Audacity without changing my sound setting I can record my microphone. I couldn't find any way of further configuring GNOME Sound Recorder which rendes it completely unusable.

Associated revisions

Revision fa20ec0b (diff)
Added by intrigeri over 2 years ago

Revert "Bring gnome-sound-recorder back": unusable in current default configuration, lacking user documentation.

refs: #11780, #10950

This reverts commits 4b9e40be686d1fa6de885e41622f6bf722f199f3
and 473e8f059e1bd059d466c4066326acdd3e3824fb.

History

#1 Updated by sajolida over 2 years ago

  • Assignee set to hybridwipe

Assigning to hybridwipe, but otherwise anonym should have a look and maybe revert this from 2.6.

#2 Updated by hybridwipe over 2 years ago

sajolida wrote:

Assigning to hybridwipe, but otherwise anonym should have a look and maybe revert this from 2.6.

This looks like https://bugs.launchpad.net/gnome-media/+bug/61211. The Ubuntu (audio) setup from a few years ago doesn't exactly match Today's tails, so this will take some more digging.

#3 Updated by intrigeri over 2 years ago

  • Parent task set to #10950

#4 Updated by intrigeri over 2 years ago

Just a random idea: in config/chroot_local-includes/etc/asound.conf we configure ALSA to use PulseAudio by default. Perhaps this config lacks some bits about inputs?

Now wearing my backup RM hat: there are less than 2 days left to get a fix in for 2.6. Any chance this happens, or should I instead revert the addition of GNOME Sound Recorder?

#5 Updated by hybridwipe over 2 years ago

intrigeri wrote:

Just a random idea: in config/chroot_local-includes/etc/asound.conf we configure ALSA to use PulseAudio by default. Perhaps this config lacks some bits about inputs?

Now wearing my backup RM hat: there are less than 2 days left to get a fix in for 2.6. Any chance this happens, or should I instead revert the addition of GNOME Sound Recorder?

Let's revert for now. Sorry for the trouble.

#6 Updated by intrigeri over 2 years ago

  • Priority changed from Elevated to Normal
  • Target version changed from Tails_2.6 to Tails_2.9.1

#7 Updated by intrigeri over 2 years ago

Let's revert for now. Sorry for the trouble.

Done. No problem! I should really have tested this myself before merging.

#8 Updated by anonym over 2 years ago

So Tails 2.6 has been delayed until 2016-09-20, so if this can be fixed until 2016-09-19 we can still make this happen. Any chances for that?

#9 Updated by hybridwipe over 2 years ago

anonym wrote:

So Tails 2.6 has been delayed until 2016-09-20, so if this can be fixed until 2016-09-19 we can still make this happen. Any chances for that?

I will have a chance to look for sure, but since I haven't figured out the issue yet, no guarantee of a fix :)

#10 Updated by hybridwipe over 2 years ago

hybridwipe wrote:

anonym wrote:

So Tails 2.6 has been delayed until 2016-09-20, so if this can be fixed until 2016-09-19 we can still make this happen. Any chances for that?

I will have a chance to look for sure, but since I haven't figured out the issue yet, no guarantee of a fix :)

sound-recorder changed substantially between the wheezy and jessie, which is what broke it. The pulse/audio bits did not. No fix yet.

#11 Updated by intrigeri over 2 years ago

FWIW this problem is still there in Tails 3.0~alpha1, after installing gnome-sound-recorder 3.21.92-1 by hand.

#12 Updated by anonym over 2 years ago

  • Target version changed from Tails_2.9.1 to Tails 2.10

#13 Updated by intrigeri over 2 years ago

  • Target version changed from Tails 2.10 to Tails_2.12

#14 Updated by intrigeri over 2 years ago

hybridwipe, any status update or ETA?

#15 Updated by hybridwipe over 2 years ago

intrigeri wrote:

hybridwipe, any status update or ETA?

So I searched my email to check the debian bug, and I found I didn't file the bug I thought that I had :(. I have filed one now:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=852870

Sorry about that!

#16 Updated by hybridwipe over 2 years ago

hybridwipe wrote:

intrigeri wrote:

hybridwipe, any status update or ETA?

So I searched my email to check the debian bug, and I found I didn't file the bug I thought that I had :(. I have filed one now:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=852870

Sorry about that!

I also filed one upstream with Gnome: https://bugzilla.gnome.org/show_bug.cgi?id=777862

#17 Updated by intrigeri over 2 years ago

I also filed one upstream with Gnome: https://bugzilla.gnome.org/show_bug.cgi?id=777862

Thanks! I'm marking the Debian bug as forwarded upstream, then.

#18 Updated by hybridwipe about 2 years ago

intrigeri wrote:

I also filed one upstream with Gnome: https://bugzilla.gnome.org/show_bug.cgi?id=777862

Thanks! I'm marking the Debian bug as forwarded upstream, then.

FYI, I've gotten a response from upstream maintainer, who thinks it's an issue with old glib. I see the issue on my debian unstable machine, with an allegedly unaffected glib, however. Investigation continues..

#19 Updated by hybridwipe about 2 years ago

hybridwipe wrote:

intrigeri wrote:

I also filed one upstream with Gnome: https://bugzilla.gnome.org/show_bug.cgi?id=777862

Thanks! I'm marking the Debian bug as forwarded upstream, then.

FYI, I've gotten a response from upstream maintainer, who thinks it's an issue with old glib. I see the issue on my debian unstable machine, with an allegedly unaffected glib, however. Investigation continues..

Turns out it was a missing gstreamer pulseaudio plugin. I've reported that to Debian. It would be simple enough to workaround by manually installing both packages (with a comment), until Debian accepts the patch.

I'll try to make a patch and test in the next couple days.

#20 Updated by intrigeri about 2 years ago

Turns out it was a missing gstreamer pulseaudio plugin. I've reported that to Debian.

Amazing!

It would be simple enough to workaround by manually installing both packages (with a comment), until Debian accepts the patch.

Agreed for 2.x (although technically it might be worth fixing the bug in Jessie). For Tails 3.0 though, let's fix that in Debian and revert our own workaround. I've proposed the maintainers to NMU.

#21 Updated by sajolida about 2 years ago

  • Status changed from Confirmed to Fix committed
  • Assignee deleted (hybridwipe)

This works now!

#22 Updated by anonym about 2 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF